Store/use os-specific settings separated for different os

RESOLVED WONTFIX

Status

()

Core
Preferences: Backend
--
enhancement
RESOLVED WONTFIX
16 years ago
6 years ago

People

(Reporter: Moritz Balz, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Some people are using their mozilla profile across different operating operating
systems - e.g. under linux on a mounted windows drive. (Similar discussion @see
bugs  12911 and 137006, for example).

If one does so, the problem raises that some preferences are suitable for only
certain operating systems. These are:
- MIME type settings (on linux mozilla always tries to open pdf files with
c:\..\acrobat.exe, I have to change this settings everytime I reboot to another os)
- Font settings
- The directory one used the last time to save downloaded files
... and maybe other settings too.

So it would make sense to me to store these settings separated for different
operating systems. This could be done without the user being bothered, by simply
adding these preferences when a new os is used.

[I know this RFE is not so important for 98% of mozilla users, but if it would
be done anytime in the future it would be great.]

Comment 1

16 years ago
backend.

currently what you can do is have multiple profiles share xp data (mail, 
bookmarks, cache) by setting each profile's preference paths for them to 
correctly reference the xp data.  but this means that other settings (um.. i'm 
not sure what those would be, probably localstore) which don't have this 
flexibility aren't shared, which is of course not ideal.

one approach would be to allow extra pref files w/ osnames to be stored in the 
pref directory and only load the appropriate one.  another would be to allow 
preferences to include another preference file (this would extend the approach i 
described earlier). in either case, i think we probably need to make sure that 
every file used by a profile can be specified by a preference.
Assignee: ben → bnesse
Status: UNCONFIRMED → NEW
Component: Preferences → Preferences: Backend
Ever confirmed: true
QA Contact: sairuh → rvelasco
(Reporter)

Comment 2

16 years ago
Since the absolute minority of all prefs is really os-specific it maybe would
make sense to keep only one prefs.js file and only give the preferences
os-identifiers. This would be easyer for the user and interoperability would
still be given for the common preferences.
e.g.
    user_pref("font.name.fantasy.x-western", "LcdD");
becomes
    user_pref("font.name.fantasy.x-western:linux", "LcdD");
    user_pref("font.name.fantasy.x-western:windows", "Comic Sans MS");
The old entry might be kept for some versions to allow downgrading.

The mimeTypes.rdf could really be a different file for each os.
Well, now.... This is an interesting suggestion.  What if I happen to run
Mozilla on two different OSes (Solaris and Linux, eg) and want to share the
profile.  Does that mean that I need to set these prefs separately on both OSes?
 Even though the operating environments basically the same?

Comment 4

16 years ago
This request poses so many potential issues that it simply boggles the mind... I
don't imagine that file prefs can be shared. Fonts are generally specific to a
platform, helper applications, target locations, browser.search.defaultengine. I
expect there may be profile specific items as well...
As part of another bug, we're thinking about partitioning profile data (of which
prefs is one example) into that which is shared by all applications of a suite
and that which is non-shareable (used only by one specific app in that suite)
Adding one more layer to this partitioning (one for the OS) may be possible.
Assignee: bnesse → nobody
QA Contact: rvelasco → preferences-backend

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.