Closed Bug 1581236 Opened 5 months ago Closed 4 months ago

Allow correct timezone with resist fingerprinting

Categories

(Core :: JavaScript: Standard Library, enhancement)

70 Branch
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1426232

People

(Reporter: shane, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.132 Safari/537.36

Steps to reproduce:

When resist fingerprinting is enabled, Firefox unconditionally reports UTC time. While it is understandable that these are batched together, the level of problems this causes with web sites is much higher than the rest of resistfingerprint's measures. It would be handy to be able to use the correct time zone without disabling the rest of the fingerprint resistance.

Thanks for taking the time to add this issue.
I'm assigning a component in order to involve the development team to have a proper review of the issue. (Core - JavaScript: Standard Library)

Component: Untriaged → JavaScript: Standard Library
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1426232
You need to log in before you can comment on or make changes to this bug.