Cache limit violated after switching platforms

RESOLVED FIXED

Status

()

Core
Networking: Cache
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: Ken Takusagawa, Assigned: gordon)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020717
BuildID:    2002071722

The disk cache limit is not observed after switching
between two Unix platforms.

Reproducible: Always
Steps to Reproduce:
1. You need a home directory crossmounted on different platforms
(e.g., NFS or AFS).  AFS in my case.
2. Start mozilla for the first time on platform A (say Sparc Solaris),
which will create a .mozilla directory.
3. You might want to set your disk cache limit to something
smaller than 50MB.
4. quit Mozilla
5. Start mozilla with the same home directory on platform B
(say i386 Linux)
6. Browse image-heavy sites, watching as the 'du' of your 
.mozilla directory goes way beyond your disk cache size.


Actual Results:  Disk cache size doesn't stop growing

Expected Results:  Disk cache size should stop growing somewhere "about" the
disk cache limit (with overhead).

The bug causes users to run out of disk quota.  The workaround
is to set the cache directory to /tmp/something.

Comment 1

16 years ago
See bug 42606 --> dupe?
(Assignee)

Comment 2

15 years ago
Are you still seeing this with more recent builds?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 3

15 years ago
Hooray! No I am not.  The bug appears to
have been fixed.

Marking fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.