Closed Bug 1581308 Opened 5 months ago Closed 5 months ago

Remove the non-functional AppMenu button that appears in the Calendar tab with Lightning enabled in SeaMonkey 2.49.5

Categories

(SeaMonkey :: Themes, defect)

defect
Not set

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.68
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: walts48, Assigned: frg)

Details

Attachments

(1 file)

Installed SM 2.49.5 64-bit over my 2.49.4 on Ubuntu 18.04.3 LTS.
Started it with my production profile.
Opened the Mail & Newsgroups Window.
Enabled the Calendar tab and noticed the text AppMenu on the right hand side of the Calendar toolbar.
Hovered my mouse pointer over it and a "Display the SeaMonkey Menu" tooltip appeared.
Clicked the AppMenu button and nothing happened.

The button shouldn't be there in SeaMonkey.

We don't implement the vertical appmenu. It could be fixed in calendar to show the button only in TB but we might want to do it later so I think it is better to just do not display it for now.

Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
Attachment #9092847 - Flags: review?(iann_bugzilla)
Attachment #9092847 - Flags: approval-comm-esr60+
Type: task → defect
Hardware: x86_64 → All
Attachment #9092847 - Flags: approval-comm-esr60+ → approval-comm-esr60?
Comment on attachment 9092847 [details] [diff] [review]
1581308-lightning-appmenu.patch

[Approval Request Comment]
Regression caused by (bug #):  -- 
User impact if declined: useless toolbar item
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none
Attachment #9092847 - Flags: approval-comm-release?
Comment on attachment 9092847 [details] [diff] [review]
1581308-lightning-appmenu.patch

[Triage Comment]
LGTM r/a=me
Attachment #9092847 - Flags: review?(iann_bugzilla)
Attachment #9092847 - Flags: review+
Attachment #9092847 - Flags: approval-comm-release?
Attachment #9092847 - Flags: approval-comm-release+
Attachment #9092847 - Flags: approval-comm-esr60?
Attachment #9092847 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/c28a66415a5f
Don't show calendar toolbar item for a non existing SeaMonkey vertical menu. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.68
You need to log in before you can comment on or make changes to this bug.