Closed Bug 1581383 Opened 1 year ago Closed 7 months ago

Labeling of default app handling in preferences is confusing for PDF files

Categories

(Firefox :: Preferences, defect, P3)

69 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 77
Tracking Status
firefox77 --- verified

People

(Reporter: niko.lecam, Assigned: jaws)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

Tried to open this pdf : https://www.gommeetgribouillages.fr/CE1/poesiejourdelarentreeboulet.pdf

Actual results:

Firefox opened tabs indefinitely

Expected results:

Only one tab and the document should be viewable.
(Works in edge BTW)

Hi Nicolas,

The issue you've described does not occur on my end, could you try using safe-mode and check if it also occurs there?
Here is a link that can help you with that: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

If it does, try making a new profile, and check again:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager

Thank you for reporting!

Flags: needinfo?(niko.lecam)

Hi Peter,

The issue happens only when Firefox is set to be the default Program to open PDF files.
This is very well describe in this support page: https://support.mozilla.org/en-US/kb/firefox-repeatedly-opens-empty-tabs-or-windows

Firefox may repeatedly open new, empty tabs or windows after you click on a link, forcing you to close Firefox.
The same untitled tabs or blank windows may open the next time you start Firefox if the previous session is restored.

This usually happens because you chose Firefox as the program to always use for a particular action, such as opening a certain type of file or launching an application to send mail. 

Thanks,
JM

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → PDF Viewer
Component: PDF Viewer → File Handling

Yes, we're aware of this issue and are working on a fix. You should be able to work around this locally by either not having Firefox as the OS default handler for PDF files, or making sure that the PDF settings in Firefox are set to show PDFs internally ("Preview in Firefox"), not use the system default handler ("Firefox (Default)").

The bug tracking the file type work is bug 215554. I know it's old, but I fixed the same bug with protocols (e.g. mailto: links) just last week in bug 1496380 for Firefox 72. I'll try to fix the file type one soon. I'd like to use this bug to fix the labels in the PDF case.

We could change the label for "App (Default)" to be "Use Windows/macOS/... default application" instead of "Firefox" when the app name is "Firefox". Or we could omit the item entirely in that case, if we also support "Preview in Firefox".

Status: UNCONFIRMED → NEW
Component: File Handling → Preferences
Ever confirmed: true
Flags: needinfo?(niko.lecam)
Summary: This pdf makes Firefox open tabs indefinitely → Labeling of default app handling in preferences is confusing for PDF files
Flags: needinfo?(gijskruitbosch+bugs)
Priority: -- → P3
Duplicate of this bug: 1609060

.

Assignee: nobody → jaws
Status: NEW → ASSIGNED
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/24437647ba33
Rename 'Preview in Firefox' to 'Open in Firefox' since 'preview' projects limited capabilities, and also change the name of the OS option when the file type can be handled internally. r=Gijs,fluent-reviewers
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/bb2c3cc73215
Rename 'Preview in Firefox' to 'Open in Firefox' since 'preview' projects limited capabilities, and also change the name of the OS option when the file type can be handled internally. r=Gijs,fluent-reviewers

Relanded with that fixed... :-)

Flags: needinfo?(jaws)
Flags: needinfo?(gijskruitbosch+bugs)
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77
Flags: qe-verify+

Confirmed that the latest beta 77.0b7 now shows Open in Firefox and Use Windows/macOS/system default application and not Preview in Firefox / Use <app> (default) for .pdf files across platforms (Windows 10 64bit, macOS 10.15.5 beta 3 and Ubuntu 18.04 64bit.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.