Closed Bug 1581411 Opened Last month Closed 25 days ago

Task list in Today Pane doesn't remember sort column and sort order

Categories

(Calendar :: General, defect)

Lightning 7.0
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ssitter, Assigned: pmorris)

References

Details

(Keywords: regression)

Attachments

(2 files)

Tested with Thunderbird 68.1.0 (Build ID 20190909201201) and Thunderbird 71.0a1 (Build ID 20190914224146).

STR: Enable task list in today pane and sort tasks by e.g. Due Date column, ascending order. Restart Thunderbird and check task list.

Actual result: Task list in today pane is not sorted.

Expected result: Task list in today pane is sorted as configured before closing Thunderbird.

Paul, in Bug 1545199 you have been working on restoring column visibility and column order. Maybe you have an idea why its not working for sort column / sort order?

Flags: needinfo?(paul)

Thanks for the report. Here's the simple fix.

Assignee: nobody → paul
Status: NEW → ASSIGNED
Flags: needinfo?(paul)
Attachment #9093438 - Flags: review?(geoff)
Comment on attachment 9093438 [details] [diff] [review]
persist-task-sort-order-0.patch

This looks like the sort of mistake I'd make! r+ assuming you've tested this is the actual cause.
Attachment #9093438 - Flags: review?(geoff) → review+
Comment on attachment 9093438 [details] [diff] [review]
persist-task-sort-order-0.patch

Yep, tested to confirm that this was the cause and the fix.  And yeah, we're not really doing ourselves any favors by using both camel case and kebab case names (sortActive and sort-active).  Forgot to request approvals.
Attachment #9093438 - Flags: approval-calendar-esr?(geoff)
Attachment #9093438 - Flags: approval-calendar-beta?(geoff)
Attachment #9093438 - Flags: approval-calendar-esr?(geoff)
Attachment #9093438 - Flags: approval-calendar-esr+
Attachment #9093438 - Flags: approval-calendar-beta?(geoff)
Attachment #9093438 - Flags: approval-calendar-beta+

Is this ready for check-in?

Flags: needinfo?(paul)

Yep, thanks for the reminder.

Flags: needinfo?(paul)
Keywords: checkin-needed

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/76f68ab2dceb
Persist task list sort column and sort order. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: Last month
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 71
Attached image sorted-not-sorted.png

Reopen because it does not work using Lightning 68.1.1 (Build ID 20190924105435, candidates/build1).

After restart of Thunderbird the column is marked with the sort arrow but the actually list content is not sorted, see screenshot.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Flags: needinfo?(paul)

Given that this is working on trunk, I was able to fix it on 68.1.1 by porting the patches from bug 1568723 and then bug 1569513 to 68 (fixing prettier formatting conflicts). But with those two patches applied, the todaypane is broken in several ways. So there must be another patch to port that these patches depend on. That's the next step. On the bright side, porting these patches should improve performance on 68.

Flags: needinfo?(paul)

Spoke too soon. Turns out it was just a one-line change that got lost during the port of bug 1568723. After fixing that the todaypane works as expected. I'll upload those ported patches to their respective bugs, and flag darktrojan for review and uplift approval.

(For some reason my 68 build is not finishing the job with Lightning. I have to manually rename the xpi file and then copy it over into the profile directory. This tripped me up because until I realized I needed to manually copy the file into the profile directory, Lightning didn't have the code changes.)

Excellent! Let's call this fixed since it's working on trunk and will be fixed elsewhere through the appropriate backports.

Status: REOPENED → RESOLVED
Closed: Last month25 days ago
Resolution: --- → FIXED
Depends on: 1568723, 1569513
Duplicate of this bug: 1584534
You need to log in before you can comment on or make changes to this bug.