Closed Bug 1581428 Opened 3 months ago Closed 3 months ago

title attributes for links in protection report not working

Categories

(Firefox :: Protections UI, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified
firefox71 --- verified

People

(Reporter: aryx, Assigned: ewright)

References

(Blocks 1 open bug, Regression)

Details

(Whiteboard: [protection-report][skyline])

Attachments

(1 file)

Firefox 71.0a1 and 70.0b6 on Windows 8.1

Bug 1570293 added the following texts for title attributes:

# This is the title attribute describing the graph report's link to about:settings#privacy
go-to-privacy-settings = Go to Privacy Settings

# This is the title attribute describing the Lockwise card's link to about:logins
go-to-saved-logins = Go to Saved Logins

These are not working: Open about:protections and move the mouse over the link mentioning the protection level - the tooltip is missing (also possible to inspect the element and see the text is missing).

They use data-l10n-title which else only gets used by the screenshots extension and there has its own localization handler: https://searchfox.org/mozilla-beta/rev/e2004eb6c1e7ddeb90353d36655391ff644e15c4/browser/extensions/screenshots/selector/ui.js#61 That might also be the option for beta here while a fix on central with a new entity with label and title would be cleaner. Francesco, can you advise, please?

Flags: needinfo?(mtigley)
Flags: needinfo?(francesco.lodolo)

This should be fixed by adding a message ID with label and title. Existing translations can be migrated via COPY_PATTERN from the existing FTL messages and, potentially, be uplifted to Beta. It all depends on timing.

Having said that, it's up to triagers to decide if an uplift is necessary.

Flags: needinfo?(francesco.lodolo)
Whiteboard: [protection-report][skyline]
Priority: -- → P1
Assignee: nobody → ewright
Status: NEW → ASSIGNED
Pushed by ewright@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8c4399f3a332
Show tooltips for links in Protection Report. r=fluent-reviewers,johannh,flod
Flags: needinfo?(ewright)
Flags: needinfo?(mtigley)
Pushed by ewright@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/45ad5999cecc
Show tooltips for links in Protection Report. r=fluent-reviewers,johannh,flod
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Given comment 1 I assume this needs a beta uplift request.

Flags: needinfo?(ewright)

(In reply to Julien Cristau [:jcristau] from comment #7)

Given comment 1 I assume this needs a beta uplift request.

indeed, thank you, I confirmed with flod that it is eligible for uplift.

Flags: needinfo?(ewright)

Comment on attachment 9093424 [details]
Bug 1581428 - Show tooltips for links in Protection Report.

Beta/Release Uplift Approval Request

  • User impact if declined: tooltips on buttons do not show up.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): ftl id and label changes, but no new strings introduced.
  • String changes made/needed: none
Attachment #9093424 - Flags: approval-mozilla-beta?

(In reply to Erica Wright [:ewright] from comment #9)

  • String changes made/needed: none

Correction: there are string changes, but they're OK (we recovered translations from existing strings).

Comment on attachment 9093424 [details]
Bug 1581428 - Show tooltips for links in Protection Report.

Add tooltips for Skyline feature, string changes approved by :flod.
OK for uplift for beta 9.

Attachment #9093424 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

I managed to reproduce the issue using an older version of Nightly (2019-09-15) on Windows 10 x64.
I retested using the latest Nightly 71.0a1 and Firefox 70.0b9 on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.13. The bug is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.