copy/paste of multiline javascript bookmark corruption

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: drench, Assigned: bugs)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.0.0) Gecko/20020620
BuildID:    20020620

Multiline Javascript bookmarks get corrupted (actually split into
individual lines it seems) when attempting to Copy and Paste them, or
drag-and-drop them, in the Bookmark Manager.

Reproducible: Always
Steps to Reproduce:
1. Visit http://home.xnet.com/~drench/js.html
2. Right click on the "Javascript with newlines" link
3. Select "Bookmark This Link"
4. From the Bookmark manager, Edit->Copy this new bookmark and Edit->Paste it
into a different folder

Actual Results:  I end up with new untitled bookmarks in the folder, one for
each line. The bookmarks obviously do not work.

Expected Results:  I would expect it to keep the bookmark intact.

A workaround is to not use copy/paste or drag/drop and use the "File
Bookmark(s)" function instead (which does work correctly).

Comment 1

16 years ago
I think this might be related to bug 67127

Comment 2

16 years ago
*** Bug 159905 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
WFM Win2k, moz1.6

Comment 4

15 years ago
Created attachment 139569 [details]
testcase

I think this is what the broken link was about.
I tried with CR-LF and with LF alone and both works. The attached one is with
Unix line feeds (reporter uses Unix).
Please say if you can still reproduce this.

Comment 5

15 years ago
It works for me also. 
Mozilla 1.6 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113
I tryed the bug  159905 also, it was good too.

Comment 6

15 years ago
->WFM (see comment #5)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.