Closed Bug 1581508 Opened 7 months ago Closed 5 months ago

Improve RSS feed display in SeaMonkey

Categories

(SeaMonkey :: MailNews: Message Display, enhancement)

enhancement
Not set

Tracking

(seamonkey2.49esr unaffected, seamonkey2.53 affected, seamonkey2.57esr fixed)

RESOLVED FIXED
seamonkey2.69
Tracking Status
seamonkey2.49esr --- unaffected
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

Attachments

(1 file)

Bug 787612 fixed an issue with printing RSS feed items
SM now behaves the same way as TB for how the display is toggled between web and summary, as mentioned by frg in that bug's comment 6, it is a bit confusing because the message is always displayed as a web page and the menu options only affect the preview in the 3pane.

Old behaviour was:
1/ In the 3pane window, if Message > Open Feed Message is set to toggle, then toggling with double click does not update the pref/view "Feed Message Body As" menu.
2/ If the message is a feed item then "Feed Message Body As" in view menu is always shown.

New behaviour will be:
1/ In the 3pane window, if Message > Open Feed Message is set to toggle, then toggling with double click updates the pref/view "Feed Message Body As" menu.
2/ If the message is a feed item then "Feed Message Body As" in view menu is only shown in the 3pane window not in a standalone message window.

I think having "Open Feed Message" under Message menu is confusing, I think it belongs in preferences but that potential change belongs in another bug.

Attached patch RSS Feed DisplaySplinter Review

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: Confusion
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None

Attachment #9092999 - Flags: review?(frgrahl)
Attachment #9092999 - Flags: approval-comm-release?
Attachment #9092999 - Flags: approval-comm-esr60?
Comment on attachment 9092999 [details] [diff] [review]
RSS Feed Display

Much better. r/a+
Attachment #9092999 - Flags: review?(frgrahl)
Attachment #9092999 - Flags: review+
Attachment #9092999 - Flags: approval-comm-release?
Attachment #9092999 - Flags: approval-comm-release+
Attachment #9092999 - Flags: approval-comm-esr60?
Attachment #9092999 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/45243122f70a
Improve RSS feed display in SeaMonkey. r=frg

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.