Closed Bug 1581582 Opened 1 year ago Closed 1 year ago

Perma [tier 2] m-fis devtools/client/inspector/rules/test/browser_rules_pseudo-visited.js | Test timed out -

Categories

(DevTools :: Inspector: Rules, defect, P3)

defect

Tracking

(Fission Milestone:M4, firefox-esr60 unaffected, firefox-esr68 unaffected, firefox69 unaffected, firefox70 unaffected, firefox71 fixed)

RESOLVED FIXED
Firefox 71
Fission Milestone M4
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: daisuke)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: malexandru [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=266881251&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/LmNINmLNQdq9uqoHmrrXxA/runs/0/artifacts/public/logs/live_backing.log


[task 2019-09-16T16:32:50.863Z] 16:32:50 INFO - TEST-OK | devtools/client/inspector/rules/test/browser_rules_pseudo-element_02.js | took 2489ms
[task 2019-09-16T16:32:50.883Z] 16:32:50 INFO - checking window state
[task 2019-09-16T16:32:50.899Z] 16:32:50 INFO - TEST-START | devtools/client/inspector/rules/test/browser_rules_pseudo-visited.js
[task 2019-09-16T16:33:36.031Z] 16:33:36 INFO - TEST-INFO | started process screentopng
[task 2019-09-16T16:33:36.372Z] 16:33:36 INFO - TEST-INFO | screentopng: exit 0
[task 2019-09-16T16:33:36.372Z] 16:33:36 INFO - Buffered messages logged at 16:32:50
[task 2019-09-16T16:33:36.373Z] 16:33:36 INFO - Entering test bound
[task 2019-09-16T16:33:36.373Z] 16:33:36 INFO - Open a particular url to make a visited link
[task 2019-09-16T16:33:36.374Z] 16:33:36 INFO - Adding a new tab with URL: http://example.com/browser/devtools/client/inspector/rules/test/doc_variables_1.html
[task 2019-09-16T16:33:36.374Z] 16:33:36 INFO - Buffered messages logged at 16:32:51
[task 2019-09-16T16:33:36.375Z] 16:33:36 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.com/browser/devtools/client/inspector/rules/test/doc_variables_1.html" line: 0}]
[task 2019-09-16T16:33:36.376Z] 16:33:36 INFO - Tab added and finished loading
[task 2019-09-16T16:33:36.376Z] 16:33:36 INFO - Loading the helper frame script chrome://mochitests/content/browser/devtools/client/inspector/rules/test/doc_frame_script.js
[task 2019-09-16T16:33:36.376Z] 16:33:36 INFO - Open tested page in the same tab
[task 2019-09-16T16:33:36.376Z] 16:33:36 INFO - Buffered messages finished
[task 2019-09-16T16:33:36.376Z] 16:33:36 INFO - TEST-UNEXPECTED-FAIL | devtools/client/inspector/rules/test/browser_rules_pseudo-visited.js | Test timed out -
[task 2019-09-16T16:33:36.376Z] 16:33:36 INFO - Removing tab.
[task 2019-09-16T16:33:36.377Z] 16:33:36 INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2019-09-16T16:33:36.380Z] 16:33:36 INFO - Got event: 'TabClose' on [object XULElement].
[task 2019-09-16T16:33:36.380Z] 16:33:36 INFO - Tab removed and finished closing
[task 2019-09-16T16:33:36.380Z] 16:33:36 INFO - GECKO(2756) | JavaScript error: resource://testing-common/PromiseTestUtils.jsm, line 112: uncaught exception: Object
[task 2019-09-16T16:33:36.380Z] 16:33:36 INFO - Console message: [JavaScript Error: "uncaught exception: Object" {file: "resource://testing-common/PromiseTestUtils.jsm" line: 112}]
[task 2019-09-16T16:33:36.381Z] 16:33:36 INFO - GECKO(2756) | MEMORY STAT | vsize 4485MB | residentFast 481MB | heapAllocated 131MB
[task 2019-09-16T16:33:36.384Z] 16:33:36 INFO - TEST-OK | devtools/client/inspector/rules/test/browser_rules_pseudo-visited.js | took 45190ms
[task 2019-09-16T16:33:36.385Z] 16:33:36 INFO - checking window state
[task 2019-09-16T16:33:36.385Z] 16:33:36 INFO - TEST-START | devtools/client/inspector/rules/test/browser_rules_pseudo_lock_options.js

Daisuke, I believe this is caused by the changes in Bug 713106, could you please take a look?

Blocks: fission
Flags: needinfo?(daisuke)
Regressed by: 713106

Alexandru, thank you very much for letting me know.
Yes, I'll take a look.

Flags: needinfo?(daisuke)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Blocks: fission-mochitests
No longer blocks: fission
Fission Milestone: --- → M4
Priority: P5 → P3
You need to log in before you can comment on or make changes to this bug.