Closed Bug 1581645 Opened 3 months ago Closed 3 months ago

Limit Inline Preview to Nightly and DevEdition

Categories

(DevTools :: Debugger, task, P2)

task

Tracking

(firefox70 fixed, firefox71 unaffected)

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed
firefox71 --- unaffected

People

(Reporter: Harald, Assigned: davidwalsh)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [debugger-mvp])

Attachments

(1 file, 1 obsolete file)

Assignee: nobody → dwalsh
Blocks: dbg-71
Attached patch beta-pref-v1.patch (obsolete) — Splinter Review

Beta/Release Uplift Approval Request

  • User impact if declined: the debugger will be 30% slower when stepping
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): we have tested inline preview disabled in the debugger
  • String changes made/needed:
Attachment #9093166 - Flags: feedback?(dwalsh)
Attachment #9093166 - Flags: approval-mozilla-beta?
Whiteboard: [debugger-mvp]
Attachment #9093166 - Flags: feedback?(dwalsh) → feedback+
Comment on attachment 9093166 [details] [diff] [review]
beta-pref-v1.patch

OK for uplift for beta 9.
Attachment #9093166 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

For future references please correct the bug number in the commit also.
The patch failed to apply correctly (hunks failed), please check if the changes are correct in the landed revision.

Flags: needinfo?(dwalsh)

Backed out changeset 63c5e3ccf355 for causing failures in browser_parsable_script.js

Backout link: https://hg.mozilla.org/releases/mozilla-beta/rev/896bb86a6cb2995245a431de09299c1890e06f45

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&resultStatus=testfailed%2Cbusted%2Cexception&tochange=896bb86a6cb2995245a431de09299c1890e06f45&fromchange=bbfbeee4593de9ea47385d88f2a109685aff233f&searchStr=%28bc&selectedJob=267921182

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=267921182&repo=mozilla-beta&lineNumber=3201

[task 2019-09-23T09:04:56.272Z] 09:04:56 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/static/browser_parsable_script.js | Script error reading jar:file:///builds/worker/workspace/build/application/firefox/browser/omni.ja!/defaults/preferences/debugger.js: SyntaxError: private fields are not currently supported -
[task 2019-09-23T09:04:56.272Z] 09:04:56 INFO - Stack trace:
[task 2019-09-23T09:04:56.272Z] 09:04:56 INFO - chrome://mochikit/content/browser-test.js:test_ok:1580
[task 2019-09-23T09:04:56.273Z] 09:04:56 INFO - chrome://mochitests/content/browser/browser/base/content/test/static/browser_parsable_script.js:parsePromise/promise</xhr.onreadystatechange:88
[task 2019-09-23T09:04:56.273Z] 09:04:56 INFO - Checking script jar:file:///builds/worker/workspace/build/application/firefox/browser/omni.ja!/chrome/devtools/modules/devtools/client/memory/utils.js
[task 2019-09-23T09:04:56.273Z] 09:04:56 INFO - Checking script jar:file:///builds/worker/workspace/build/application/firefox/browser/omni.ja!/chrome/devtools/modules/devtools/client/memory/dominator-tree-lazy-children.js
[task 2019-09-23T09:04:56.274Z] 09:04:56 INFO - Checking script jar:file:///builds/worker/workspace/build/application/firefox/browser/omni.ja!/chrome/devtools/modules/devtools/client/jsonview/components/HeadersPanel.js
[task 2019-09-23T09:04:56.274Z] 09:04:56 INFO - Checking script jar:file:///builds/worker/workspace/build/application/firefox/browser/omni.ja!/chrome/devtools/modules/devtools/client/inspector/flexbox/reducers/flexbox.js
[task 2019-09-23T09:04:56.274Z] 09:04:56 INFO - Checking script jar:file:///builds/worker/workspace/build/application/firefox/browser/omni.ja!/chrome/browser/content/pocket/panels/js/tmpl.js
[task 2019-09-23T09:04:56.274Z] 09:04:56 INFO - Checking script jar:file:///builds/worker/workspace/build/application/firefox/browser/omni.ja!/chrome/browser/content/pocket/panels/js/sendtomobile.js
[task 2019-09-23T09:04:56.276Z] 09:04:56 INFO - Checking script jar:file:///builds/worker/workspace/build/application/firefox/browser/omni.ja!/chrome/browser/content/browser/customizableui/panelUI.js
[task 2019-09-23T09:04:56.277Z] 09:04:56 INFO - Checking script jar:file:///builds/worker/workspace/build/application/firefox/browser/omni.ja!/chrome/devtools/modules/devtools/shared/fronts/actor-registry.js
[task 2019-09-23T09:04:56.277Z] 09:04:56 INFO - Checking script jar:file:///builds/worker/workspace/build/application/firefox/browser/omni.ja!/chrome/devtools/modules/devtools/server/actors/webconsole/listeners/content-process.js

Flags: needinfo?(jlaster)

I apologize, it looks like this pref had a syntax error. I'll push a simplified patch now

Flags: needinfo?(jlaster)

Beta/Release Uplift Approval Request

  • User impact if declined:
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky):
  • String changes made/needed:
Attachment #9093166 - Attachment is obsolete: true
Attachment #9094592 - Flags: approval-mozilla-beta?
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Attachment #9094592 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: needinfo?(dwalsh)
You need to log in before you can comment on or make changes to this bug.