Closed Bug 1581749 Opened 2 years ago Closed 2 years ago

[macOS] 1x20px artifact after toggling hover state of info button in Protections Panel

Categories

(Core :: Graphics, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected

People

(Reporter: tbabos, Unassigned, NeedInfo)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Affected versions
Nightly 71.0a1 (2019-09-16)
Beta 70.0b7

Affected platforms
only MacOS

Steps to reproduce

  • Launch Firefox
  • Go to any site, such as reddit
  • Click on the shield icon
  • Click on the 'i' button to focus it
  • Click again
  • Hover over any other items from the panel

Expected result
The 'i' button should be correctly unfocused

Actual Result
There will be a slightly visible vertical bar on the right side of the button. Recording: https://streamable.com/55i2t

This seems to be a graphical artifact. It's reproducible by toggling :hover in the inspector a few times till it appears. If you try and hover on other nodes in the inspector (causing a red dotted outline to be drawn) something gets flushed and the artifact goes away.

Changing this to Core :: Graphics. Sorry if this turns out to not be the appropriate component.

Component: Site Identity and Permission Panels → Graphics
Product: Firefox → Core
Summary: [Protection Panel][macOS] Unintended vertical bar is displayed on the right side of the "i" button after unfocusing → [macOS] 1px artifact after toggling hover state of info button in Protections Panel
Version: unspecified → Trunk
Summary: [macOS] 1px artifact after toggling hover state of info button in Protections Panel → [macOS] 1x20px artifact after toggling hover state of info button in Protections Panel
Blocks: 1573445

Markus, could this be caused by recent CoreAnimation/WebRender work?

Flags: needinfo?(mstange)
Whiteboard: [privacy-panel][skyline]

Oh, whoops. This was leftover in my triage queue, and seems fairly important.

I don't think this will be webrender related, because it isn't enabled on Mac yet. I couldn't reproduce on Linux or Windows.

Jessie, I don't have a Mac to reproduce on. I know there are quite a few in the Toronto office should somebody there take a look?

Flags: needinfo?(jbonisteel)

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

Timea, can you still reproduce this? I tried Nightly 71.0a1 (2019-10-02) on my Mac 10.13.6 and could not reproduce

Flags: needinfo?(jbonisteel)

See comment 5, also please attach your about:support (mostly wondering if you forced WebRender on or not). Thanks!

Flags: needinfo?(tbabos)

Can't reproduce anymore on the latest Nightly and Beta. Also, didn't force enable WebRender before as it is not intended for Mac OS for now.
Closing this as resolved:worksforme.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(tbabos)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.