Closed Bug 1581753 Opened 28 days ago Closed 18 days ago

Improve one-off search button layout in very narrow windows

Categories

(Firefox :: Address Bar, defect, P1)

defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 71
Iteration:
71.2 - Sept 16 - 29
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified
firefox71 --- verified

People

(Reporter: cfogel, Assigned: dao)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

Attached image search_notResponsive.png (obsolete) —

Affected versions

  • 70.0b7, 71.0a1 (2019-09-05) ;

Affected platforms

  • Windows 10, Ubuntu 18.40, macOS 10.12;

Steps to reproduce

  1. Launch Firefox ;
  2. Resize the browser to @ 1/4 width of the screen;
  3. Click to open the address bar;

Expected result

  • One-of search options are displayed in the screen;

Actual result

  • The dropdown has a min-width that is fixed and does not take in account the resize;
  • buttons get truncated instead of being shifted into a visible position(space is available for it);

Regression range

  • Potential regressor: 1561894

Additional notes

  • attached screenshot with the issue;

Adding Harry for a second opinion; in case this issue can be fixed with another existing bug.

Flags: needinfo?(htwyford)

(In reply to Cristian Fogel, QA [:cfogel] from comment #0)

Affected versions

  • 70.0b7, 71.0a1 (2019-09-05) ;

This appears to be an old Nightly, please update.

Flags: needinfo?(cristian.fogel)
Attached image 09.16.png

Good point.
However, while with 71.0a1 (2019-09-16) the buttons are somewhat in order but the text before them is still fixed and taking up allot of the available space.

Flags: needinfo?(cristian.fogel)

This is working as intended in comment 3's screenshot. I'm cc'ing Verdi just so he's aware of the UX here.

Flags: needinfo?(htwyford)
Type: defect → enhancement
Priority: -- → P5
Summary: One-off search buttons - section not responsive when shrinking the browser width → Improve one-off search button layout in very narrow windows
Duplicate of this bug: 1581630
Blocks: megabar
Type: enhancement → defect
Has Regression Range: --- → yes

Verdi produced a spec for this that resizes with the page: https://firefox.michaelverdi.com/squish/. The minimum row width should match the length of the localized string.

Attachment #9093218 - Attachment is obsolete: true
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Priority: P5 → P1

I'm going to post a simple upliftable patch that I think addresses the main concern here and file a followup for verdi's more complex layout proposal.

Iteration: --- → 71.2 - Sept 16 - 29
Points: --- → 2

Please remember to file the follow-up today, and make it block the megabar, we must meetup to discuss the path forward.

Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c6ceaf18bea3
Improve one-off search button layout in narrow windows. r=mak
Blocks: 1584253
Status: ASSIGNED → RESOLVED
Closed: 18 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Flags: qe-verify+

Comment on attachment 9095544 [details]
Bug 1581753 - Improve one-off search button layout in narrow windows. r=mak

Beta/Release Uplift Approval Request

  • User impact if declined: see comment 3
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: reduce the window width and type something in the address bar
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Pretty simple fix
  • String changes made/needed:
Attachment #9095544 - Flags: approval-mozilla-beta?
Attached image verdiSpec.png

With 71.0a1(2019-09-29) the main issue seems to be addressed.
However as per comment 6, one more improvement can be made for this case; the buttons being pushed bellow the "This time, search with:" text when bellow a certain width.

Should we file a separate bug/enhancement for it?

Flags: needinfo?(dao+bmo)

(In reply to Cristian Fogel, QA [:cfogel] from comment #13)

With 71.0a1(2019-09-29) the main issue seems to be addressed.
However as per comment 6, one more improvement can be made for this case; the buttons being pushed bellow the "This time, search with:" text when bellow a certain width.

Should we file a separate bug/enhancement for it?

We already filed bug 1584253 on this.

Flags: needinfo?(dao+bmo)

Awesome, thank you for the prompt reply!
Marking the issue verified for nightly.
Keeping the QE flag until we get the beta-fix approved & checked.

Status: RESOLVED → VERIFIED

Comment on attachment 9095544 [details]
Bug 1581753 - Improve one-off search button layout in narrow windows. r=mak

CSS fix, verified in nightly, let's uplift for beta 12.

Attachment #9095544 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Fix verified with 70.0b12 as well.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.