Closed Bug 1581760 Opened 5 months ago Closed 5 months ago

Remove use of proxy.* in test_ext_alias.js

Categories

(Thunderbird :: Add-Ons: Extensions API, task, P3)

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 71.0

People

(Reporter: darktrojan, Assigned: darktrojan)

References

Details

Attachments

(1 file)

The proxy API functions are doomed in bug 1545811. We use them in a test but there's no reason to keep that part around.

Priority: -- → P3

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/5adfca66df89
Port bug 1443259 - remove deprecated proxy APIs; rs=bustage-fix

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Duplicate of this bug: 1584093

Since you wrote this Philipp, you're probably the best person to check it. I don't think we need to replace it with anything.

Assignee: nobody → geoff
Attachment #9095437 - Flags: review?(philipp)
Target Milestone: --- → Thunderbird 71.0
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/5c78e1c5ef34
Follow-up: Remove now unmatched ExtensionTestUtils.failOnSchemaWarnings(true) call. r=me DONTBUILD
Comment on attachment 9095437 [details] [diff] [review]
1581760-remove-proxy-1.diff

Review of attachment 9095437 [details] [diff] [review]:
-----------------------------------------------------------------

Nope, nothing we need to replace this with. browser.proxy.register was replaced with browser.proxy.onRequest.addListener()
Attachment #9095437 - Flags: review?(philipp) → review+
You need to log in before you can comment on or make changes to this bug.