Status

()

Core
Plug-ins
RESOLVED WONTFIX
16 years ago
16 years ago

People

(Reporter: rogerl (gone), Assigned: rubydoo123)

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [awaiting comments from reproter])

(Reporter)

Description

16 years ago
Following mail received from "yxy" <iscp1087@nus.edu.sg>

Hi,I am a research student of National University of Singapore. I am committing
an experiment on netscape. I bumped into some problems with it. Could u help
me?The experiment is to implement a plugin to check the content of the coming
HTML page and pop up another window to show whether the content meets our
need.The following are some problems:
1.As for the plugin, i set MIME to  "application\x-html-plugin" and the suffix
to "html". i append a normal web page with such a sentence "<embed
src=xxx.html>". xxx.html is the file name of the normal web page but not the
URL. In my experiment, I found that sometimes netscape would retrieve the web
page once again before as the input of the plugin and sometimes it would
directly input the web page to the plugin to handle. Why so? Since it is the
most important for my experiment to have delat as little as possible, i wonder
if there is any way to let netscape just input the web page to the plugin but
not retrieve it once more. 
2. I wonder the sequence of the display and the parse of a web page. is it your
implementation to display the web page while parse it? If yes, then why the
title of the web page is first displayed but the content of web page is
displayed after return from the plugin in my experiment ? 
3. how to pop up another window with the template program that netscape has
provided in its SDK? i found both "windowed" and "windowless" window embedded
into the original window that was displaying the content of a web page. So is it
any way to implement our idea? looking forwards to your reply.
cheers,yuxiaoyan
(Reporter)

Comment 1

16 years ago
Reponse from Beth Epperson:

What plug-in is the reporter using that maps to the mime-type specified? For
example, Flash is mapped to application/x-shockwave-flash. When we encounter
that mime-type, we know to launch Flash. Our application as a whole responds to
.html file extensions, so that part has me a bit confused. In any event, I need
to know a couple more things:

In the About Plugins page, does that specified mime type show up? Can they
copy/paste the entire section for that plug-in information?

How exactly are they coding the embed element? How we resolve the plug-in is by
this:
1. we analyze the embed element and look to see if there is a type attribute
present (this is clearly the preferred method), if the type attribute is not
present, then
2. we analyze the extension. This is where I think we might be having the
doubling issue since the extension is .html, or
3. we receive the mime type from the http header

It would be extremely helpful, actually it is a must have kind of thing, to have
them load the plug-in where we can access to it. Then provide us with a test
page so we can see what is happening.
(Reporter)

Comment 2

16 years ago
Cc'ing reporter to get response...
(Assignee)

Updated

16 years ago
Whiteboard: [awaiting comments from reproter]
(Assignee)

Comment 3

16 years ago
Since this one has been sitting around awhile without any feedback from the
reporter, I am going to close this one out. Roger, we would gladly help out if
the person contacts you again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.