Closed Bug 1581928 Opened 2 years ago Closed 2 years ago

A lot of wpt failures of CSS Transitions and Animations on Windows 7 and AArch64 only

Categories

(Core :: CSS Transitions and Animations, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1578125

People

(Reporter: boris, Unassigned)

Details

There are a lot of interpolation failures on wpt, on window 7 and AArch64 only.
e.g.

  • testing/web-platform/meta/css/css-align/animation/column-gap-interpolation.html.ini
  • testing/web-platform/meta/css/css-backgrounds/animations/background-color-interpolation.html.ini
  • testing/web-platform/meta/css/css-color/animation/color-interpolation.html.ini
  • testing/web-platform/meta/css/css-flexbox/animation/flex-grow-interpolation.html.ini
  • testing/web-platform/meta/css/css-fonts/animations/font-size-adjust-interpolation.html.ini
  • testing/web-platform/meta/css/css-transforms/animation/transform-interpolation-001.html.ini
  • ... and others.

Perhaps it is because of the update of the interpolation framework from WPT PR 8402. However, this only happens on Windows 7 and AArch64, so need someone who uses the Windows environment to check.

Windows 7 and AArch64 failures, but not Win10 failures, seems like an odd combination. Are we calling out to libm somewhere, and we're getting different results on those two platforms than we would on Win10? (But I would expect Win10 and AArch64 to be using roughly the same libm, so...)

May be fixed by bug 1578125. The issue seems to be the very large times introduced in the changes to the interpolation framework that end up being treated as infinite times on Windows because of the differently underlying implementation of TimeStamp.

(In reply to Brian Birtles (:birtles) from comment #2)

May be fixed by bug 1578125. The issue seems to be the very large times introduced in the changes to the interpolation framework that end up being treated as infinite times on Windows because of the differently underlying implementation of TimeStamp.

Great. This is good news. :)

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1578125
You need to log in before you can comment on or make changes to this bug.