Closed Bug 1581956 Opened 7 months ago Closed 7 months ago

Make search-textbox not use the <textbox> tag

Categories

(Toolkit :: XUL Widgets, task)

task
Not set

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: ntim, Assigned: ntim)

References

Details

Attachments

(1 file)

No description provided.
Blocks: 1513325

Existing callers looking for the textbox tag: https://searchfox.org/mozilla-central/search?q=nsGkAtoms%3A%3Atextbox&case=false&regexp=false&path=. Hopefully we don't need to port all of these, and we can get i.e. a11y working by relying on the normal html:input a11y plus aria attributes. If we needed to port all the existing platform code and tests to include an additional tag name, then we may not gain a lot by changing the tag name here.

I would have assumed the migration path for this one would be <html:input type="search" is="something">

(In reply to Magnus Melin [:mkmelin] from comment #3)

I would have assumed the migration path for this one would be <html:input type="search" is="something">

We can't use is="" here because it doesn't let us append child elements (clear button/search icon).
It would be ideal to just use <input type=search> directly, but we'd need to implement the clear button in bug 558594.

Blocks: 1583713
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/aa7f20ae7699
Make search-textbox not use the <textbox> tag. r=surkov,MarcoZ
Regressions: 1584004
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Assignee: nobody → ntim.bugs
Regressions: 1596193
You need to log in before you can comment on or make changes to this bug.