Closed Bug 1581997 Opened 10 months ago Closed 4 months ago

Exceptions for WebXR api's should include an informative message.

Categories

(Core :: WebVR, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1614496

People

(Reporter: kip, Unassigned)

References

(Blocks 1 open bug)

Details

Instead of using the following when throwing nsresults/DOMExceptions:

ErrorResult::Throw(nsresult)
ErrorResult::operator=(nsresult)

We should instead use:

ErrorResult::ThrowDOMException(nsresult, const nsACString&)

which allows passing a message string that explains why the exception is
being thrown.

All exceptions in Bug 1614496 (WebXR core implementation) now include an informative message.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1614496
You need to log in before you can comment on or make changes to this bug.