Closed Bug 1582073 Opened 5 months ago Closed 5 months ago

Icons for web handlers no longer loaded in preferences application list

Categories

(Firefox :: Preferences, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- verified

People

(Reporter: Gijs, Assigned: ckerschb)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STR:

  1. open prefs
  2. search for "appli"
  3. select the mailto, irc or ircs rows
  4. open the action dropdown on the right

ER:
icons show up for mibbit/gmail/yahoo mail

AR:
no icons show up, CSP error in the console

Christoph, can you take a look? Should we just add https://* to the img-src list?

Flags: needinfo?(ckerschb)
Priority: -- → P3
Priority: P3 → --

I agree with the original P3 assessment, so putting that back, but putting a needinfo on jaws in case there's anything here I'm missing.

Flags: needinfo?(jaws)
Priority: -- → P3

Yeah P3 is what I wanted here but I removed it due to the open needinfo. I'm fine with leaving it now.

Flags: needinfo?(jaws)

(In reply to :Gijs (he/him) from comment #0)

Christoph, can you take a look? Should we just add https://* to the img-src list?

yes we should - thanks for filing the bug. Adding https: to img-src resolves the problem.

Assignee: nobody → ckerschb
Status: NEW → ASSIGNED
Flags: needinfo?(ckerschb)
Priority: P3 → P1
Keywords: checkin-needed

Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/01855d5dc2eb
Add https: to img-src directive for CSP of about:preferences. r=Gijs

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Flags: qe-verify+

I've reproduce this issue with Fx 71.0a1 (2019-09-18) on Windows 10 x64.
The issue is verified fixed with Fx 72.0a1 (2019-11-03) and Fx 71.0b6 on Windows 10 x64, macOS 10.15 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.