Closed Bug 1582119 Opened 3 months ago Closed 3 months ago

Perma TEST-UNEXPECTED-FAIL | dom/base/test/browser_use_counters.js | page counts for CSS_PROPERTY_BackgroundImage after are correct - Got 0, expected 1 when Gecko 71 merges to Beta on 2019-10-14

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 + verified

People

(Reporter: malexandru, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Central as beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&revision=1fdd59700f9f352a087fbe8697d2f962aa18b021

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=267248449&repo=try&lineNumber=5418
[task 2019-09-18T12:55:43.559Z] 12:55:43 INFO - TEST-UNEXPECTED-FAIL | dom/base/test/browser_use_counters.js | page counts for CSS_PROPERTY_BackgroundImage after are correct - Got 0, expected 1
[task 2019-09-18T12:55:43.561Z] 12:55:43 INFO - Stack trace:
[task 2019-09-18T12:55:43.561Z] 12:55:43 INFO - chrome://mochikit/content/browser-test.js:test_is:1595
[task 2019-09-18T12:55:43.561Z] 12:55:43 INFO - chrome://mochitests/content/browser/dom/base/test/browser_use_counters.js:check_use_counter_iframe:251
[task 2019-09-18T12:55:43.562Z] 12:55:43 INFO - TEST-PASS | dom/base/test/browser_use_counters.js | top level document counts are correct -
[task 2019-09-18T12:55:43.562Z] 12:55:43 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-09-18T12:55:43.562Z] 12:55:43 INFO - TEST-UNEXPECTED-FAIL | dom/base/test/browser_use_counters.js | document counts for CSS_PROPERTY_BackgroundImage after are correct - Got 0, expected 1
[task 2019-09-18T12:55:43.563Z] 12:55:43 INFO - Stack trace:
[task 2019-09-18T12:55:43.563Z] 12:55:43 INFO - chrome://mochikit/content/browser-test.js:test_is:1595
[task 2019-09-18T12:55:43.563Z] 12:55:43 INFO - chrome://mochitests/content/browser/dom/base/test/browser_use_counters.js:check_use_counter_iframe:261
[task 2019-09-18T12:55:43.563Z] 12:55:43 INFO - checking file_use_counter_style.html with histogram CSS_PROPERTY_Padding
[task 2019-09-18T12:55:43.563Z] 12:55:43 INFO - Console message: [JavaScript Warning: "The character encoding of a framed document was not declared. The document may appear different if viewed without the document framing it." {file: "http://example.com/browser/dom/base/test/file_use_counter_style.html" line: 0}]
[task 2019-09-18T12:55:48.787Z] 12:55:48 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-09-18T12:55:48.787Z] 12:55:48 INFO - TEST-UNEXPECTED-FAIL | dom/base/test/browser_use_counters.js | page counts for CSS_PROPERTY_Padding after are correct - Got 0, expected 1
[task 2019-09-18T12:55:48.788Z] 12:55:48 INFO - Stack trace:
[task 2019-09-18T12:55:48.788Z] 12:55:48 INFO - chrome://mochikit/content/browser-test.js:test_is:1595
[task 2019-09-18T12:55:48.788Z] 12:55:48 INFO - chrome://mochitests/content/browser/dom/base/test/browser_use_counters.js:check_use_counter_iframe:251
[task 2019-09-18T12:55:48.790Z] 12:55:48 INFO - TEST-PASS | dom/base/test/browser_use_counters.js | top level document counts are correct -
[task 2019-09-18T12:55:48.791Z] 12:55:48 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-09-18T12:55:48.791Z] 12:55:48 INFO - TEST-UNEXPECTED-FAIL | dom/base/test/browser_use_counters.js | document counts for CSS_PROPERTY_Padding after are correct - Got 0, expected 1
[task 2019-09-18T12:55:48.791Z] 12:55:48 INFO - Stack trace:
[task 2019-09-18T12:55:48.792Z] 12:55:48 INFO - chrome://mochikit/content/browser-test.js:test_is:1595
[task 2019-09-18T12:55:48.792Z] 12:55:48 INFO - chrome://mochitests/content/browser/dom/base/test/browser_use_counters.js:check_use_counter_iframe:261
[task 2019-09-18T12:55:48.792Z] 12:55:48 INFO - checking file_use_counter_style.html with histogram CSS_PROPERTY_MozTransform
[task 2019-09-18T12:55:48.975Z] 12:55:48 INFO - Console message: [JavaScript Warning: "The character encoding of a framed document was not declared. The document may appear different if viewed without the document framing it." {file: "http://example.com/browser/dom/base/test/file_use_counter_style.html" line: 0}]
[task 2019-09-18T12:55:54.273Z] 12:55:54 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-09-18T12:55:54.273Z] 12:55:54 INFO - TEST-UNEXPECTED-FAIL | dom/base/test/browser_use_counters.js | page counts for CSS_PROPERTY_MozTransform after are correct - Got 0, expected 1
[task 2019-09-18T12:55:54.273Z] 12:55:54 INFO - Stack trace:
[task 2019-09-18T12:55:54.273Z] 12:55:54 INFO - chrome://mochikit/content/browser-test.js:test_is:1595
[task 2019-09-18T12:55:54.273Z] 12:55:54 INFO - chrome://mochitests/content/browser/dom/base/test/browser_use_counters.js:check_use_counter_iframe:251
[task 2019-09-18T12:55:54.274Z] 12:55:54 INFO - TEST-PASS | dom/base/test/browser_use_counters.js | top level document counts are correct -
[task 2019-09-18T12:55:54.274Z] 12:55:54 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-09-18T12:55:54.274Z] 12:55:54 INFO - TEST-UNEXPECTED-FAIL | dom/base/test/browser_use_counters.js | document counts for CSS_PROPERTY_MozTransform after are correct - Got 0, expected 1
[task 2019-09-18T12:55:54.275Z] 12:55:54 INFO - Stack trace:
[task 2019-09-18T12:55:54.275Z] 12:55:54 INFO - chrome://mochikit/content/browser-test.js:test_is:1595
[task 2019-09-18T12:55:54.275Z] 12:55:54 INFO - chrome://mochitests/content/browser/dom/base/test/browser_use_counters.js:check_use_counter_iframe:261
[task 2019-09-18T12:55:54.276Z] 12:55:54 INFO - checking file_use_counter_style.html with histogram CSS_PROPERTY_WebkitPaddingStart
[task 2019-09-18T12:55:54.473Z] 12:55:54 INFO - Console message: [JavaScript Warning: "The character encoding of a framed document was not declared. The document may appear different if viewed without the document framing it." {file: "http://example.com/browser/dom/base/test/file_use_counter_style.html" line: 0}]
[task 2019-09-18T12:55:59.771Z] 12:55:59 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-09-18T12:55:59.771Z] 12:55:59 INFO - TEST-UNEXPECTED-FAIL | dom/base/test/browser_use_counters.js | page counts for CSS_PROPERTY_WebkitPaddingStart after are correct - Got 0, expected 1
[task 2019-09-18T12:55:59.772Z] 12:55:59 INFO - Stack trace:
[task 2019-09-18T12:55:59.772Z] 12:55:59 INFO - chrome://mochikit/content/browser-test.js:test_is:1595
[task 2019-09-18T12:55:59.772Z] 12:55:59 INFO - chrome://mochitests/content/browser/dom/base/test/browser_use_counters.js:check_use_counter_iframe:251
[task 2019-09-18T12:55:59.773Z] 12:55:59 INFO - TEST-PASS | dom/base/test/browser_use_counters.js | top level document counts are correct -
[task 2019-09-18T12:55:59.773Z] 12:55:59 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-09-18T12:55:59.773Z] 12:55:59 INFO - TEST-UNEXPECTED-FAIL | dom/base/test/browser_use_counters.js | document counts for CSS_PROPERTY_WebkitPaddingStart after are correct - Got 0, expected 1
[task 2019-09-18T12:55:59.773Z] 12:55:59 INFO - Stack trace:
[task 2019-09-18T12:55:59.773Z] 12:55:59 INFO - chrome://mochikit/content/browser-test.js:test_is:1595
[task 2019-09-18T12:55:59.773Z] 12:55:59 INFO - chrome://mochitests/content/browser/dom/base/test/browser_use_counters.js:check_use_counter_iframe:261
[task 2019-09-18T12:55:59.773Z] 12:55:59 INFO - checking file_use_counter_svg_getElementById.svg with histogram SVGSVGELEMENT_GETELEMENTBYID
[task 2019-09-18T12:56:00.893Z] 12:56:00 INFO - TEST-PASS | dom/base/test/browser_use_counters.js | page counts for SVGSVGELEMENT_GETELEMENTBYID after are correct -
[task 2019-09-18T12:56:00.894Z] 12:56:00 INFO - TEST-PASS | dom/base/test/browser_use_counters.js | top level document counts are correct -

Emilio, this seems to be caused by the changes in Bug 1578661, could you please take a look at it?

Flags: needinfo?(emilio)
Assignee: nobody → emilio

(Yes, we disable css use counters in beta, thus this failure, will enable the right prefs on the test, or something)

Flags: needinfo?(emilio)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d20aa9568b30
Enable CSS use counters in use counter test. r=heycam
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
You need to log in before you can comment on or make changes to this bug.