Closed Bug 1582210 Opened 10 months ago Closed 9 months ago

Support splitting blob images into different sizes

Categories

(Core :: Graphics: WebRender, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: jrmuizel, Assigned: jrmuizel)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(1 file)

Currently if we split a blob image the first image gets the same size as the subsequent image. It would be quite beneficial to performance to instead have blob images sized to the bounds of the items that they contain.

Blocks: blob-perf
Blocks: 1582152
Blocks: 1556163
Duplicate of this bug: 1583880

The basic idea here would be to just union the BlobItemData.mRects for a given group and then intersect this rectangle with initial visible rect and use the result as the visible rect for the blob.

This makes things better especially when the bounds of the combined blob
is changing but the bound of the separate ones are not.

The current implementation is a bit ugly, but it's simple and
can be cleaned up in the cleanups I have in mind for the future.

Depends on: 1586055
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4c696f6996de
Support splitting blob images into different sizes. r=nical
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Assignee: nobody → jmuizelaar
You need to log in before you can comment on or make changes to this bug.