Filter Edit window is slow to spawn when filter contains many rules

RESOLVED WORKSFORME

Status

MailNews Core
Filters
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Greg K., Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1b) Gecko/20020718
BuildID:    

When a message filter contains many rules (e.g., 30), the Edit Filter window
takes a considerable amount of time to appear. In my case, it takes
approximately 13 seconds for one of my ten named filters to appear, and it has
30 rules in it.

Reproducible: Always
Steps to Reproduce:
1. Configure a message filter with approximately 30 rules
2. Select Tools/Message Filters, select the filter, and click Edit

Actual Results:  Mozilla takes approximately 13 seconds to display the filter
editing window.

Expected Results:  The window should appear in much less time.
(Reporter)

Updated

16 years ago
Keywords: perf
(Reporter)

Updated

16 years ago
Keywords: mail1

Comment 1

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021003

I get similar behaviour on Windows 2000. A filter with 20 rules takes about 7-8
seconds to appear.

Comment 2

15 years ago
confirmed - 2003013108 - win98. Already a very noticable difference with just a
small larger number of filter rules.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: MacOS X → All
Hardware: Macintosh → All

Comment 3

15 years ago
*** Bug 176628 has been marked as a duplicate of this bug. ***
mass re-assign.
Assignee: naving → sspitzer
Product: MailNews → Core

Comment 5

12 years ago
is this working better?

WFM Thunderbird version 3 alpha 1 (20060317)
<2 seconds to open edit of 30+ rules
Assignee: sspitzer → nobody
QA Contact: laurel

Comment 6

10 years ago
closing WFM
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.