Closed Bug 1582435 Opened 2 years ago Closed 4 months ago

Make the way highlighters-overlay retrieves and stores HighlighterFront instances so it is compatible with Fission

Categories

(DevTools :: Inspector, defect, P3)

defect

Tracking

(Fission Milestone:MVP)

RESOLVED DUPLICATE of bug 1646028
Fission Milestone MVP

People

(Reporter: pbro, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: dt-fission-reserve)

This is probably quite a lot of work to do in the highlighters-overlay.js file to make it work correctly with Fission.

One example is the way it shows the flexbox highlighter here.
It retrieves one global highlighter instance where, really, it should retrieve the one that's contextual to the process where the highlighted node lives.

Highlighter instances are cached by type but really this should be by target and type instead.

Tentatively moving all bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to the "?" triage milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → ?

Tracking for enabling Fission in Nightly (M6)

Fission Milestone: ? → M6

dt-fission-reserve bugs do not need to block Fission Nightly (M6), but these bugs' summaries mention the word "Fission", so let's track them for Fission riding the trains to Beta (M7). We'll revisit these bugs before we ship Fission.

Fission Milestone: M6 → M7

Tracking dt-fission-reserve bugs for Fission MVP until we know whether they really need to block Fission or not.

Fission Milestone: M7 → MVP

This was fixed for HighlighterFront along with the Box Model Highlighter refactoring in Bug 1646028
Other highlighters, like Flexbox Highlighter, are being addressed independently in their own bugs.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1646028
You need to log in before you can comment on or make changes to this bug.