Closed Bug 1582440 Opened 1 year ago Closed 1 year ago

Perma devtools/client/netmonitor/test/browser_net_basic-search.js | Test timed out -, when Gecko 71 merges to Beta on 2019-10-14

Categories

(DevTools :: Netmonitor, defect)

defect
Not set
normal

Tracking

(firefox-esr60 unaffected, firefox-esr68 unaffected, firefox69 unaffected, firefox70 unaffected, firefox71+ fixed)

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 + fixed

People

(Reporter: cbrindusan, Assigned: lloanalas)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Central as beta simulation:
https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=df646d8e466666827a2833b5a45e44d773033a39

Failure log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=267418765&repo=try&lineNumber=5178

[task 2019-09-19T10:50:03.059Z] 10:50:03 INFO - TEST-START | devtools/client/netmonitor/test/browser_net_basic-search.js
[task 2019-09-19T10:50:03.065Z] 10:50:03 INFO - GECKO(1748) | ++DOCSHELL 0x10ab45000 == 1 [pid = 1753] [id = {d52fefb9-ad8a-1840-b525-93a70aa53540}]
[task 2019-09-19T10:50:03.066Z] 10:50:03 INFO - GECKO(1748) | ++DOMWINDOW == 1 (0x113737020) [pid = 1753] [serial = 3] [outer = 0x0]
[task 2019-09-19T10:50:03.066Z] 10:50:03 INFO - GECKO(1748) | ++DOMWINDOW == 2 (0x10b42bc00) [pid = 1753] [serial = 4] [outer = 0x113737020]
[task 2019-09-19T10:50:03.152Z] 10:50:03 INFO - GECKO(1748) | ++DOMWINDOW == 3 (0x145c49800) [pid = 1753] [serial = 5] [outer = 0x113737020]
[task 2019-09-19T10:50:03.316Z] 10:50:03 INFO - GECKO(1748) | --DOCSHELL 0x1241b8000 == 9 [pid = 1748] [id = {b0495350-d051-984a-8f46-b1214fef473c}] [url = chrome://devtools/content/inspector/markup/markup.xhtml]
[task 2019-09-19T10:50:03.460Z] 10:50:03 INFO - GECKO(1748) | ++DOCSHELL 0x115ca5800 == 10 [pid = 1748] [id = {19f13b75-cb0a-e54c-9b2d-0c46c9fa883c}]
[task 2019-09-19T10:50:03.460Z] 10:50:03 INFO - GECKO(1748) | ++DOMWINDOW == 26 (0x10430f980) [pid = 1748] [serial = 56] [outer = 0x0]
[task 2019-09-19T10:50:03.460Z] 10:50:03 INFO - GECKO(1748) | ++DOMWINDOW == 27 (0x1170dc800) [pid = 1748] [serial = 57] [outer = 0x10430f980]
[task 2019-09-19T10:50:03.460Z] 10:50:03 INFO - GECKO(1748) | ++DOMWINDOW == 28 (0x1166af400) [pid = 1748] [serial = 58] [outer = 0x10430f980]
[task 2019-09-19T10:50:03.532Z] 10:50:03 INFO - GECKO(1748) | ++DOMWINDOW == 29 (0x1176b8c00) [pid = 1748] [serial = 59] [outer = 0x10430f980]
[task 2019-09-19T10:50:03.562Z] 10:50:03 INFO - GECKO(1748) | [Parent 1748, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file /builds/worker/workspace/build/src/dom/base/nsContentUtils.cpp, line 3659
[task 2019-09-19T10:50:03.837Z] 10:50:03 INFO - GECKO(1748) | ++DOCSHELL 0x11652c800 == 11 [pid = 1748] [id = {aee7aa03-9d08-d245-bd8a-65f8e1daf48e}]
[task 2019-09-19T10:50:03.838Z] 10:50:03 INFO - GECKO(1748) | ++DOMWINDOW == 30 (0x122d6e3e0) [pid = 1748] [serial = 60] [outer = 0x0]
[task 2019-09-19T10:50:03.838Z] 10:50:03 INFO - GECKO(1748) | ++DOMWINDOW == 31 (0x117626000) [pid = 1748] [serial = 61] [outer = 0x122d6e3e0]
[task 2019-09-19T10:50:04.188Z] 10:50:04 INFO - GECKO(1748) | [Parent 1748, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, nullptr) failed with result 0x804B000A: file /builds/worker/workspace/build/src/extensions/permissions/nsPermission.cpp, line 42
[task 2019-09-19T10:50:04.188Z] 10:50:04 INFO - GECKO(1748) | [Parent 1748, Main Thread] WARNING: '!principal', file /builds/worker/workspace/build/src/netwerk/cookie/CookieSettings.cpp, line 132
[task 2019-09-19T10:50:04.188Z] 10:50:04 INFO - GECKO(1748) | [Parent 1748, Main Thread] WARNING: 'NS_FAILED(rv)', file /builds/worker/workspace/build/src/toolkit/components/antitracking/StorageAccess.cpp, line 33
[task 2019-09-19T10:50:04.476Z] 10:50:04 INFO - GECKO(1748) | ++DOMWINDOW == 4 (0x1116e7000) [pid = 1753] [serial = 6] [outer = 0x113737020]
[task 2019-09-19T10:50:06.017Z] 10:50:06 INFO - GECKO(1748) | --DOCSHELL 0x108846800 == 2 [pid = 1751] [id = {0df9ba32-442f-0f42-a0da-7b0babfd2377}] [url = http://example.com/browser/devtools/client/netmonitor/test/html_custom-get-page.html]
[task 2019-09-19T10:50:06.017Z] 10:50:06 INFO - GECKO(1748) | --DOCSHELL 0x114a46800 == 1 [pid = 1752] [id = {d9595c77-515e-c947-9dfa-32ce731c6048}] [url = about:blank]
[task 2019-09-19T10:50:06.017Z] 10:50:06 INFO - GECKO(1748) | --DOCSHELL 0x11c408000 == 0 [pid = 1752] [id = {272a7a2b-5a15-7443-947f-5fcdf6d85633}] [url = http://example.com/browser/devtools/client/netmonitor/test/html_infinite-get-page.html]
[task 2019-09-19T10:50:06.027Z] 10:50:06 INFO - GECKO(1748) | --DOCSHELL 0x109c11800 == 1 [pid = 1751] [id = {9087dffe-d680-2f45-984b-a417371889fe}] [url = about:blank]
[task 2019-09-19T10:50:06.088Z] 10:50:06 INFO - GECKO(1748) | --DOMWINDOW == 5 (0x11c439020) [pid = 1752] [serial = 5] [outer = 0x0] [url = http://example.com/browser/devtools/client/netmonitor/test/html_infinite-get-page.html]
[task 2019-09-19T10:50:06.088Z] 10:50:06 INFO - GECKO(1748) | --DOMWINDOW == 8 (0x12083a5c0) [pid = 1751] [serial = 7] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:06.088Z] 10:50:06 INFO - GECKO(1748) | --DOMWINDOW == 7 (0x12083a020) [pid = 1751] [serial = 10] [outer = 0x0] [url = http://example.com/browser/devtools/client/netmonitor/test/html_custom-get-page.html]
[task 2019-09-19T10:50:06.935Z] 10:50:06 INFO - GECKO(1748) | --DOMWINDOW == 30 (0x120196800) [pid = 1748] [serial = 45] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:06.935Z] 10:50:06 INFO - GECKO(1748) | --DOMWINDOW == 29 (0x1170e4c00) [pid = 1748] [serial = 46] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:06.935Z] 10:50:06 INFO - GECKO(1748) | --DOMWINDOW == 28 (0x12836cc00) [pid = 1748] [serial = 53] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:06.935Z] 10:50:06 INFO - GECKO(1748) | --DOMWINDOW == 27 (0x122907800) [pid = 1748] [serial = 41] [outer = 0x0] [url = about:devtools-toolbox]
[task 2019-09-19T10:50:06.935Z] 10:50:06 INFO - GECKO(1748) | --DOMWINDOW == 26 (0x1229ec000) [pid = 1748] [serial = 43] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:06.935Z] 10:50:06 INFO - GECKO(1748) | --DOCSHELL 0x104374800 == 10 [pid = 1748] [id = {16a419d5-0b77-584c-bb81-3f2fedb95226}] [url = chrome://devtools/content/netmonitor/index.html]
[task 2019-09-19T10:50:06.935Z] 10:50:06 INFO - GECKO(1748) | --DOCSHELL 0x116527800 == 9 [pid = 1748] [id = {096d0d2c-c3ca-c944-a039-e164f2bb80d0}] [url = about:devtools-toolbox]
[task 2019-09-19T10:50:06.935Z] 10:50:06 INFO - GECKO(1748) | --DOCSHELL 0x120139800 == 8 [pid = 1748] [id = {720a8ab3-7183-f841-890b-5a129c5d4c67}] [url = chrome://devtools/content/inspector/index.xhtml]
[task 2019-09-19T10:50:10.405Z] 10:50:10 INFO - GECKO(1748) | --DOMWINDOW == 6 (0x109cd4c00) [pid = 1751] [serial = 12] [outer = 0x0] [url = http://example.com/browser/devtools/client/netmonitor/test/html_custom-get-page.html]
[task 2019-09-19T10:50:10.406Z] 10:50:10 INFO - GECKO(1748) | --DOMWINDOW == 5 (0x108918400) [pid = 1751] [serial = 15] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:10.406Z] 10:50:10 INFO - GECKO(1748) | --DOMWINDOW == 4 (0x109cde800) [pid = 1751] [serial = 13] [outer = 0x0] [url = http://example.com/browser/devtools/client/netmonitor/test/html_custom-get-page.html]
[task 2019-09-19T10:50:10.406Z] 10:50:10 INFO - GECKO(1748) | --DOMWINDOW == 3 (0x143e1cc00) [pid = 1751] [serial = 9] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:10.406Z] 10:50:10 INFO - GECKO(1748) | --DOMWINDOW == 2 (0x108897800) [pid = 1751] [serial = 11] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:10.512Z] 10:50:10 INFO - GECKO(1748) | --DOMWINDOW == 4 (0x10dd2d400) [pid = 1752] [serial = 9] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:10.513Z] 10:50:10 INFO - GECKO(1748) | --DOMWINDOW == 3 (0x10dc97c00) [pid = 1752] [serial = 6] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:10.513Z] 10:50:10 INFO - GECKO(1748) | --DOMWINDOW == 2 (0x11c9c1800) [pid = 1752] [serial = 7] [outer = 0x0] [url = http://example.com/browser/devtools/client/netmonitor/test/html_infinite-get-page.html]
[task 2019-09-19T10:50:10.554Z] 10:50:10 INFO - GECKO(1748) | --DOMWINDOW == 1 (0x11c4393e0) [pid = 1752] [serial = 8] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:11.453Z] 10:50:11 INFO - GECKO(1748) | --DOMWINDOW == 25 (0x1170dc800) [pid = 1748] [serial = 57] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:11.453Z] 10:50:11 INFO - GECKO(1748) | --DOMWINDOW == 24 (0x1166af400) [pid = 1748] [serial = 58] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:11.968Z] 10:50:11 INFO - GECKO(1748) | [Parent 1748, Main Thread] WARNING: NS_ENSURE_TRUE(!mHasOrHasHadOwnerWindow || mOwnerWindow) failed: file /builds/worker/workspace/build/src/dom/events/DOMEventTargetHelper.cpp, line 318
[task 2019-09-19T10:50:11.968Z] 10:50:11 INFO - GECKO(1748) | [Parent 1748, Main Thread] WARNING: NS_ENSURE_TRUE(!mHasOrHasHadOwnerWindow || mOwnerWindow) failed: file /builds/worker/workspace/build/src/dom/events/DOMEventTargetHelper.cpp, line 318
[task 2019-09-19T10:50:11.968Z] 10:50:11 INFO - GECKO(1748) | [Parent 1748, Main Thread] WARNING: NS_ENSURE_TRUE(!mHasOrHasHadOwnerWindow || mOwnerWindow) failed: file /builds/worker/workspace/build/src/dom/events/DOMEventTargetHelper.cpp, line 318
[task 2019-09-19T10:50:11.968Z] 10:50:11 INFO - GECKO(1748) | [Parent 1748, Main Thread] WARNING: NS_ENSURE_TRUE(!mHasOrHasHadOwnerWindow || mOwnerWindow) failed: file /builds/worker/workspace/build/src/dom/events/DOMEventTargetHelper.cpp, line 318
[task 2019-09-19T10:50:11.984Z] 10:50:11 INFO - GECKO(1748) | --DOMWINDOW == 23 (0x10430f7a0) [pid = 1748] [serial = 48] [outer = 0x0] [url = chrome://devtools/content/netmonitor/index.html]
[task 2019-09-19T10:50:11.984Z] 10:50:11 INFO - GECKO(1748) | --DOMWINDOW == 22 (0x12ccd36a0) [pid = 1748] [serial = 50] [outer = 0x0] [url = chrome://devtools/content/inspector/index.xhtml]
[task 2019-09-19T10:50:11.984Z] 10:50:11 INFO - GECKO(1748) | --DOMWINDOW == 21 (0x10430f5c0) [pid = 1748] [serial = 44] [outer = 0x0] [url = about:devtools-toolbox]
[task 2019-09-19T10:50:11.984Z] 10:50:11 INFO - GECKO(1748) | --DOMWINDOW == 20 (0x12ccd3a60) [pid = 1748] [serial = 54] [outer = 0x0] [url = chrome://devtools/content/inspector/markup/markup.xhtml]
[task 2019-09-19T10:50:14.926Z] 10:50:14 INFO - GECKO(1748) | --DOMWINDOW == 0 (0x114abb000) [pid = 1752] [serial = 10] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:16.108Z] 10:50:16 INFO - GECKO(1748) | --DOMWINDOW == 19 (0x123113c00) [pid = 1748] [serial = 49] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:16.108Z] 10:50:16 INFO - GECKO(1748) | --DOMWINDOW == 18 (0x151f8b000) [pid = 1748] [serial = 51] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:16.108Z] 10:50:16 INFO - GECKO(1748) | --DOMWINDOW == 17 (0x12310bc00) [pid = 1748] [serial = 47] [outer = 0x0] [url = about:devtools-toolbox]
[task 2019-09-19T10:50:16.108Z] 10:50:16 INFO - GECKO(1748) | --DOMWINDOW == 16 (0x12836c400) [pid = 1748] [serial = 55] [outer = 0x0] [url = chrome://devtools/content/inspector/markup/markup.xhtml]
[task 2019-09-19T10:50:46.581Z] 10:50:46 INFO - GECKO(1748) | --DOMWINDOW == 3 (0x10b42bc00) [pid = 1753] [serial = 4] [outer = 0x0] [url = about:blank]
[task 2019-09-19T10:50:46.581Z] 10:50:46 INFO - GECKO(1748) | --DOMWINDOW == 2 (0x145c49800) [pid = 1753] [serial = 5] [outer = 0x0] [url = http://example.com/browser/devtools/client/netmonitor/test/html_custom-get-page.html]
[task 2019-09-19T10:51:33.190Z] 10:51:33 INFO - TEST-INFO | started process screencapture
[task 2019-09-19T10:51:33.341Z] 10:51:33 INFO - TEST-INFO | screencapture: exit 0
[task 2019-09-19T10:51:33.341Z] 10:51:33 INFO - Buffered messages logged at 10:50:03
[task 2019-09-19T10:51:33.343Z] 10:51:33 INFO - Entering test bound
[task 2019-09-19T10:51:33.343Z] 10:51:33 INFO - Initializing a network monitor pane.
[task 2019-09-19T10:51:33.343Z] 10:51:33 INFO - Adding a new tab with URL: http://example.com/browser/devtools/client/netmonitor/test/html_custom-get-page.html
[task 2019-09-19T10:51:33.343Z] 10:51:33 INFO - Tab added and finished loading
[task 2019-09-19T10:51:33.343Z] 10:51:33 INFO - Net tab added successfully: http://example.com/browser/devtools/client/netmonitor/test/html_custom-get-page.html
[task 2019-09-19T10:51:33.343Z] 10:51:33 INFO - Buffered messages logged at 10:50:04
[task 2019-09-19T10:51:33.343Z] 10:51:33 INFO - Network monitor pane shown successfully.
[task 2019-09-19T10:51:33.343Z] 10:51:33 INFO - Disabling cache and reloading page.
[task 2019-09-19T10:51:33.343Z] 10:51:33 INFO - Request server0.conn6.netEvent4 for http://example.com/browser/devtools/client/netmonitor/test/html_custom-get-page.html not yet done, keep waiting...
[task 2019-09-19T10:51:33.343Z] 10:51:33 INFO - Got marker: dom-interactive
[task 2019-09-19T10:51:33.345Z] 10:51:33 INFO - Got marker: dom-complete
[task 2019-09-19T10:51:33.345Z] 10:51:33 INFO - Got two timeline markers, done waiting
[task 2019-09-19T10:51:33.345Z] 10:51:33 INFO - Console message: [JavaScript Warning: "Relative positioning of table rows and row groups is now supported. This site may need to be updated because it may depend on this feature having no effect." {file: "resource://devtools/client/netmonitor/src/components/RequestListHeader.js" line: 440}]
[task 2019-09-19T10:51:33.346Z] 10:51:33 INFO - Request server0.conn6.netEvent4 for http://example.com/browser/devtools/client/netmonitor/test/html_custom-get-page.html done
[task 2019-09-19T10:51:33.347Z] 10:51:33 INFO - All requests finished[task 2019-09-19T10:51:33.347Z] 10:51:33 INFO - Cache disabled when the current and all future toolboxes are open.
[task 2019-09-19T10:51:33.347Z] 10:51:33 INFO - TEST-PASS | devtools/client/netmonitor/test/browser_net_basic-search.js | Request to reconfigure the tab was recorded. -
[task 2019-09-19T10:51:33.347Z] 10:51:33 INFO - Clearing requests in the console client.
[task 2019-09-19T10:51:33.347Z] 10:51:33 INFO - Clearing requests in the UI.
[task 2019-09-19T10:51:33.348Z] 10:51:33 INFO - Starting test...
[task 2019-09-19T10:51:33.348Z] 10:51:33 INFO - Buffered messages logged at 10:50:05
[task 2019-09-19T10:51:33.349Z] 10:51:33 INFO - > Network event progress: NetworkEvent: 1/2, PayloadReady: 0/2, got NetMonitor:NetworkEvent for server0.conn6.netEvent23
[task 2019-09-19T10:51:33.349Z] 10:51:33 INFO - > Network event progress: NetworkEvent: 1/2, PayloadReady: 1/2, got NetMonitor:PayloadReady for server0.conn6.netEvent23
[task 2019-09-19T10:51:33.350Z] 10:51:33 INFO - > Network event progress: NetworkEvent: 2/2, PayloadReady: 1/2, got NetMonitor:NetworkEvent for server0.conn6.netEvent43
[task 2019-09-19T10:51:33.350Z] 10:51:33 INFO - > Network event progress: NetworkEvent: 2/2, PayloadReady: 2/2, got NetMonitor:PayloadReady for server0.conn6.netEvent43
[task 2019-09-19T10:51:33.350Z] 10:51:33 INFO - Buffered messages finished
[task 2019-09-19T10:51:33.350Z] 10:51:33 INFO - TEST-UNEXPECTED-FAIL | devtools/client/netmonitor/test/browser_net_basic-search.js | Test timed out -

Iloan, this seems to be caused by the changes in Bug 1579784, could you please take a look at it?

Flags: needinfo?(lloanalas)

Taking a look - thanks!

Flags: needinfo?(lloanalas)

(copying from Slack so, it isn't forgotten)

@Lloan, you can try to replace waitForDOM by waitForDOMIfNeeded (perhaps the DOM is already modified and we are waiting for DOM changes that already happened) https://searchfox.org/mozilla-central/rev/e18057a9613ffda06dfd3640209ca234ed7dc37d/devtools/client/netmonitor/test/head.js#1140

Honza

Flags: needinfo?(lloanalas)

Honza,

Patch created.

Thanks for the reminder!

Flags: needinfo?(lloanalas) → needinfo?(odvarko)

Does devtools.netmonitor.features.search need to be switched to true? It's false on beta:
https://searchfox.org/mozilla-central/rev/e3fc8f8970491aef14d3212b2d052942f4d29818/browser/app/profile/firefox.js#2101

The screenshot for the failure in comment 0 - https://taskcluster-artifacts.net/H8A44BMgSTiuTIiTNPOYPw/0/public/test_info/mozilla-test-fail-screenshot_szukis.png - shows an empty sidebar on the left after the test calle store.dispatch(Actions.openSearch()); directly.

Assignee: nobody → lloanalas
Status: NEW → ASSIGNED
Flags: needinfo?(odvarko)
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d87cd33857dc
Test time out when merging Gecko 71 to Beta. r=Honza

Sebastian & Honza,

We had another patch that was landed already (I believe) to set that to true on Beta.

Flags: needinfo?(lloanalas)

https://hg.mozilla.org/mozilla-central/rev/d50134f27f21b6896d330e76505dbf544a8e4230 removed the comment about DevEdition and Beta (still enabled for DevEdition).

Setting leave-open as the issue is not resolved by the latest push (see comment 6).

Keywords: leave-open

(In reply to lloan alas:[lloanalas] from comment #9)

Sebastian & Honza,

We had another patch that was landed already (I believe) to set that to true on Beta.

We enabled the feature on Nightly and DevEdition, not beta, bug 1581088.
So, this could be the problem!

@Lloan, please put the following at the beginning of the test:
await pushPref("devtools.netmonitor.features.search", true);

Honza

Flags: needinfo?(lloanalas)

@Honza

Will do - does this mean we have another issue in that we didn't enable it in Beta, but only Nightly and Dev? (separate bug?)

Thanks!

Flags: needinfo?(lloanalas)

Turning on search feature for test

Turned on search feature for test.

Will reach out regarding creating a bug for turning this on in Beta.

Flags: needinfo?(odvarko)
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4e30a8c3f7a6
Test continues to time out when merging Gecko 71 to Beta. r=Honza

(In reply to lloan alas:[lloanalas] from comment #13)

Will do - does this mean we have another issue in that we didn't enable it in Beta, but only Nightly and Dev? (separate bug?)

I created bug 1583446 for enabling the feature in all channels.

Thanks Lloan for updating the patch here!
Honza

Flags: needinfo?(odvarko)
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
You need to log in before you can comment on or make changes to this bug.