Page info should list the alt for images in the media-tab in the tree.

RESOLVED FIXED in mozilla1.2alpha

Status

--
enhancement
RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: nick, Assigned: nick)

Tracking

Trunk
mozilla1.2alpha

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 7 obsolete attachments)

(Assignee)

Description

17 years ago
It was very handy to easily check which images had alt attributes and which
images lacked one of those.
(Assignee)

Comment 1

17 years ago
Created attachment 91911 [details] [diff] [review]
Patch v1.0

I've added a new row to the <tree>, I've made it hidden by default.

This is the first XUL patch I ever contribute to Mozilla! =)
(Assignee)

Updated

17 years ago
Keywords: patch
(Assignee)

Comment 2

17 years ago
Created attachment 91919 [details] [diff] [review]
v1.1: Removed extra colon
Attachment #91911 - Attachment is obsolete: true
Comment on attachment 91919 [details] [diff] [review]
v1.1: Removed extra colon

Use hasAttribute() to test attribute existence.
Attachment #91919 - Flags: needs-work+
(Assignee)

Comment 4

17 years ago
Created attachment 91992 [details] [diff] [review]
Uses hasAttribute. Fixes bug in detailed view.

I've found a bug in the detailed view. An alt="", isn't the same as "not
specified", but as "" evaluates to false it regards such alt attribute as
non-existant.
Attachment #91919 - Attachment is obsolete: true
(Assignee)

Comment 5

17 years ago
Created attachment 91996 [details] [diff] [review]
Ops! Uses hasChildNodes().
Attachment #91992 - Attachment is obsolete: true
Comment on attachment 91996 [details] [diff] [review]
Ops! Uses hasChildNodes().

>+  if(item.hasAttribute("alt"))
>+    altText = item.alt;

This is no good.  <div alt="foo"> will test true for hasAttribute("alt") and
give a strict warning with that code.  You need to test both
hasAttribute("alt") and |"alt" in item|

also, space between "if" and "(" please, here and right after that.
Attachment #91996 - Flags: needs-work+
(Assignee)

Comment 7

17 years ago
Created attachment 92062 [details] [diff] [review]
Shows an italic "empty string" for alt="" in detailed view

Well.. I'll stop addding things so this can be reviewed and (hopefully) checked
in.. =)
Attachment #91996 - Attachment is obsolete: true
> +  if (altText=="") {

If this is true, that means alt text is set.  Why does it matter whether the
textbox is italic if its contents are the empty string?
Comment on attachment 92062 [details] [diff] [review]
Shows an italic "empty string" for alt="" in detailed view

what's with the stars in notSet?
> +emptystring=empty string

Capitalize that, and sr=bzbarsky
(Assignee)

Comment 11

17 years ago
Created attachment 92068 [details] [diff] [review]
emptystring -> emptyString
Attachment #92062 - Attachment is obsolete: true
(Assignee)

Comment 12

17 years ago
I've filed a new bug, bug 158425 to put all those "Not specified" strings in
italics :).
I think he meant "Empty String" :)
Also, while you're working on this bug look for the bug where someone asks me to
add all the things that show up in the detail area as (hidden) columns in the
tree. Now that you've got this one under your belt, the others should be a snap.
(Assignee)

Comment 15

17 years ago
Taking it as me, as adviced on IRC =).
Assignee: db48x → nick
(Assignee)

Comment 16

17 years ago
Created attachment 92070 [details] [diff] [review]
emptyString -> emptystring, "empty string" -> "Empty String"

Hehe.. done.. =)

db48x: sure, It will be nice to have the other values there. Another thing I
was thinking is.. the "no." row is useless for most people, why don't we hide
it by default?
Attachment #92068 - Attachment is obsolete: true
Comment on attachment 92070 [details] [diff] [review]
emptyString -> emptystring, "empty string" -> "Empty String"

+  var notSet = "*" + theBundle.getString("notset") + "*"

take the * out of this, and r=db48x

Also, feel free to hide the number column in this and any other tab it's not
hidden by default. I must have forgotten to fix it, I must have hidden them
with the colpicker and forgotten about the bug.
(Assignee)

Comment 18

17 years ago
Boo, I liked the starts. The idea was to make that text stand-out from the real
specified text. But that text should be in italic anyway...
Comment on attachment 92070 [details] [diff] [review]
emptyString -> emptystring, "empty string" -> "Empty String"

sr=bzbarsky once db48x's comment is addressed.
Attachment #92070 - Flags: review+
(Assignee)

Comment 20

17 years ago
Created attachment 92071 [details] [diff] [review]
No more starts, "no." hidden by default.

Done.
Attachment #92070 - Attachment is obsolete: true
(Assignee)

Updated

17 years ago
Attachment #92071 - Flags: superreview+
Attachment #92071 - Flags: review+
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Comment on attachment 92071 [details] [diff] [review]
No more starts, "no." hidden by default.

yea, r=db48x. who have you asked to check this in?
(Assignee)

Comment 22

17 years ago
I've emailed drivers@mozilla.org, as I read in mozillazine. Besides that I
haven't asked anybody anything...
(Assignee)

Updated

17 years ago
Keywords: approval

Comment 23

17 years ago
Comment on attachment 92071 [details] [diff] [review]
No more starts, "no." hidden by default.

a=scc for checkin to the mozilla TRUNK, after 1.1b tag/branch is cut
Attachment #92071 - Flags: approval+
(Assignee)

Updated

17 years ago
Keywords: approval
Target Milestone: --- → mozilla1.2alpha
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.