Closed Bug 1582471 Opened 4 months ago Closed 4 months ago

[Protections Panel] The focus indicator overlaps the toggle button

Categories

(Firefox :: Site Identity, defect)

All
Windows
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified
firefox71 --- verified

People

(Reporter: emilghitta, Assigned: timhuang)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [privacy-panel][skyline])

Attachments

(2 files)

Attached image Screenshot_55.png

Affected versions

  • 71.0a1 (BuildId:20190919094654)
  • 70.0b7 (BuildId:20190916074538)

Affected platforms

  • Windows 10 64bit

Unaffected platforms

  • macOS 10.13.6
  • Ubuntu 18.04 64bit.

Steps to reproduce

  1. Launch Firefox.
  2. Open any web page.
  3. Click the shield icon to open the protections panel.
  4. Press the “Tab” several times to focus on the TP switch.

Expected result
The focus indicator does not overlap the toggle button.

Actual result
The focus indicator overlaps the toggle button.

Regression Range
I don’t think that this is a regression

Notes
For further information regarding this issue please observe the attached screenshot.
I am reproducing this issue with 70.0b8 (provided in Bug 1578052 , comment 9) as well.

Assignee: nobody → tihuang
Status: NEW → ASSIGNED

On Windows, there is a global CSS rule to set 'outline-offset' to -2px
on toolbarbuttons. We need to unset it on the TP switch button in order
to make the focus indicator to work correctly.

Pushed by tihuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0add1eb7bd28
Unset the CSS 'outline-offset' rule for the TP switch when it gets focused on Windows. r=nhnt11
Type: task → defect
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Comment on attachment 9094118 [details]
Bug 1582471 - Unset the CSS 'outline-offset' rule for the TP switch when it gets focused on Windows. r?nhnt11!

Beta/Release Uplift Approval Request

  • User impact if declined: The focus indicator would overlap the TP switch on Window.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Launch Firefox.
  1. Open any web page.
  2. Click the shield icon to open the protections panel.
  3. Press the “Tab” several times to focus on the TP switch.
  4. Check if the focus indicator overlaps the TP switch.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This patch only adds one CSS rule. So, it's low risk.
  • String changes made/needed: None
Attachment #9094118 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9094118 [details]
Bug 1582471 - Unset the CSS 'outline-offset' rule for the TP switch when it gets focused on Windows. r?nhnt11!

Low risk one liner css patch, uplift approved for 70 beta 9, thanks.

Attachment #9094118 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: needinfo?(emil.ghitta)
QA Whiteboard: [qa-triaged]

I was able to reproduce the issue using an affected Nightly build (2019-09-09), and by following the steps from comment 0.

The issue is verified fixed on latest Nightly 71.0a1 and Beta 70.0b9, under Windows 10 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(emil.ghitta)

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
You need to log in before you can comment on or make changes to this bug.