Closed Bug 1582505 Opened 2 months ago Closed 2 months ago

When openViewOnFocus is enabled, focusing the urlbar with a shortcut on the new tab page opens the view

Categories

(Firefox :: Address Bar, defect, P1)

defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox69 --- wontfix
firefox70 --- verified
firefox71 --- verified

People

(Reporter: mak, Assigned: mak)

References

Details

Attachments

(1 file)

on the new tab page we should not auto open the view, but we do because in browser.js we check .openViewOnFocus instead of openViewOnFocusForCurrentTab

Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/a511ef7cdbef
OpenViewOnFocus should not open the view on the new tab page using a shortcut. r=adw
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Comment on attachment 9093959 [details]
Bug 1582505 - OpenViewOnFocus should not open the view on the new tab page using a shortcut. r=adw

Beta/Release Uplift Approval Request

  • User impact if declined: No direct user impact because the option is disabled by default, but we plan to test this feature through experiments on Beta
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Type a few urls in the urlbar and visit them, so that the empty search dropdown is populated (from the new tab page click on the urlbar dropdown and check there's something)
    Set browser.urlbar.openViewOnFocus to true, in the new tab page CTRL+L should focus the urlbar AND open the results view.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The feature is disabled by default and intended for experiments
  • String changes made/needed:
Attachment #9093959 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

I reproduced this issue with Fx 71.0a1 (2019-09-19) on Windows 10 x64.
The issue is verified fixed with Fx 71.0a1 (2019-09-24) on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64.

Comment on attachment 9093959 [details]
Bug 1582505 - OpenViewOnFocus should not open the view on the new tab page using a shortcut. r=adw

Support for planned beta experiments, let's uplift for beta 10. Verified in Nightly.

Attachment #9093959 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

This Issue is also verified fixed with Fx 70.0b10 (treeherder build) on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.