If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When composing new messages, added attachments can't be removed from mail being composed.

CLOSED WORKSFORME

Status

MailNews Core
Composition
CLOSED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Mitja Stantiè, Assigned: varada)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

When composing new messages, added attachments can't be removed from mail beeing
composed. Right mouse button seems to work only to the "body" area (right click
on the attachment gives Delete and Select all commands, which both works on the
message body). I'd expected keystroke DEL to remove attachment, bu it doesn't work.
I'll really appreciate the possibillity of removing attached files when
composing new messages.

Reproducible: Always
Steps to Reproduce:
1. Begin composing new mail.
2. Add a attachment.
3. Try to remove attached file from attachment list...

Actual Results:  Nothing (that's the problem).

Expected Results:  On keystroke DEL, on popup action "Delete attachment"
(doesn't exsist yet) or better on "drag-and-drop" away the attachment from the
list in the upper right corner, the selected attachment SHOULD BE REMOVED FROM
THE ATTACHMENT LIST.

Updated

15 years ago
QA Contact: esther → trix
Summary: When composing new messages, added attachments can't be removed from mail beeing composed. → When composing new messages, added attachments can't be removed from mail being composed.

Comment 1

15 years ago
Works for me with build 2002070308.
Can you please try with a current nightly?

Comment 2

15 years ago
Perhaps I could recall a bug where del key wasn't functioning in attachments
pane. But there's no problem in current builds. And context menu deletion is
available too. Marking as wfm.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 3

15 years ago
verified wfm
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

15 years ago
I've tried with nighty build 2002080319 and realised something "interesting". If
I'm using theme "wood" (http://themes.mozdev.org/themes4.html) I can stil
reproduce this bug. But if I'm using theme "modern", I can't reproduce the bug.
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---
reassign to varada
Assignee: ducarroz → varada
(Assignee)

Comment 6

15 years ago
Marking as wfm.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

15 years ago
Wfm on themes Classic, Modern, IE, Orbit... still doesn't work on theme Wood.
Tested on 2 PC. Seems to be a bug on Wood theme. Please mark bug "Closed" if
themes can cause bugs like this.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

15 years ago
This bug probably depends on the theme used. I won't waste your precious time
any more. Marking as Closed.
Status: VERIFIED → CLOSED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.