Closed Bug 1582713 Opened 3 months ago Closed 3 months ago

When What's New toolbar button is active the Overflow Menu position is changed in Customize Firefox

Categories

(Firefox :: Toolbars and Customization, defect, P1, minor)

defect

Tracking

()

VERIFIED FIXED
Firefox 71
Iteration:
71.2 - Sept 16 - 29
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- wontfix
firefox70 --- fixed
firefox71 --- verified

People

(Reporter: atrif, Assigned: andreio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

Attached image overflow_01.png

Affected versions

  • 70.0b8 (20190902191027)
  • 71.0a1 (20190919184237)

Affected platforms

  • Windows 10x64
  • Ubuntu 18.04
  • macOS 10.14

Preconditions

  • Make sure What's New toolbar button is active (if not open Fx with a new profile and wait like 5-7 min).

Steps to reproduce

  1. Open Firefox and go to Customize Menu.
  2. Observe the Overflow section on the top right.

Expected result

  • Overflow Menu is correctly displayed under the expected icon.

Actual result

  • Overflow Menu is displayed under What's New toolbar button.

Regression range

  • Reproducible on Firefox 70.0a1(20190729095501). I will search for one ASAP.

Additional Notes

  • Attached a screenshot.
Has Regression Range: --- → no
Has STR: --- → yes
Regressed by: 1561345

Hm. I wonder if we should be hiding that button while in Customize Mode (as I imagine it can't be customized via Customize Mode, considering its placement next to the appmenu button). That might be simplest option.

What do you think, r1cky?

Flags: needinfo?(rrosario)
Priority: -- → P3

Passing it on to :andreio.

Flags: needinfo?(rrosario) → needinfo?(andrei.br92)

(In reply to Mike Conley (:mconley) (:⚙️) from comment #1)

Hm. I wonder if we should be hiding that button while in Customize Mode (as I imagine it can't be customized via Customize Mode, considering its placement next to the appmenu button). That might be simplest option.

Thanks that's a good idea.

Assignee: nobody → andrei.br92
Iteration: --- → 71.2 - Sept 16 - 29
Flags: needinfo?(andrei.br92)
Priority: P3 → P1
Pushed by aoprea@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bdd3e554925b
Hide the What's New button from the toolbar when in Customize mode r=Gijs
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Hello! The issue is verified with Firefox 71.0a1 (20190925215653) on Windows 10x64, macOS 10.14 and Ubuntu 18.04. The What's New toolbar button is successfully hidden when entering the Customize menu.

Status: RESOLVED → VERIFIED
Has Regression Range: no → yes

Is this something we should uplift to Beta for Skyline?

Flags: needinfo?(andrei.br92)

Comment on attachment 9094938 [details]
Bug 1582713 - Hide the What's New button from the toolbar when in Customize mode

Beta/Release Uplift Approval Request

  • User impact if declined: UI regression in Customize mode
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small CSS change that has been verified by QA
  • String changes made/needed: n/a
Flags: needinfo?(andrei.br92)
Attachment #9094938 - Flags: approval-mozilla-beta?

Comment on attachment 9094938 [details]
Bug 1582713 - Hide the What's New button from the toolbar when in Customize mode

Polish for skyline, css fix, verified in nightly.
OK for uplift for beta 12.

Attachment #9094938 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.