Closed Bug 1582751 Opened 5 months ago Closed 3 months ago

In the "Report a Broken Site" sub panel the input text still remains even after is was submitted.

Categories

(Firefox :: Protections UI, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 72
Tracking Status
firefox-esr68 --- unaffected
firefox69 --- wontfix
firefox70 - wontfix
firefox71 --- wontfix
firefox72 --- verified

People

(Reporter: oana.botisan, Assigned: johannh)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [privacy-panel][skyline])

Attachments

(2 files)

Affected versions

  • Firefox 71.a01
  • Firefox 70.0b8

Affected platforms

  • Windows 10 x64
  • Ubuntu 18.04 x64
  • macOS 10.14

Steps to reproduce

  1. Go to reddit.com and click on the shield icon from URL bar.
  2. Click on "Site not working?" and then on "Send report".
  3. Write a comment and then submit it.
  4. Repeat steps 1 - 3 and observe the behaviour.

Expected result

  • The dialog box is empty.

Actual result

  • The dialog box still has the previous comment written.

Regression range

  • Last good: 2019-09-01
  • First bad: 2019-09-02
  • Mozregression concluded that bug 1548475 might have caused the issue, but I am not sure how that is possible.

Additional notes

  • Please look at the attached gif.
  • As far as I can tell the issue is reproducing only on the sites that trackers are detected on.

I can't reproduce this, can you check for errors in the browser console when submitting the report?

Flags: needinfo?(oana.botisan)
Whiteboard: [privacy-panel][skyline]

This is the error I got:
Content Blocking report to https://tracking-protection-issues.herokuapp.com/new failed with status 422
submitBreakageReport chrome://browser/content/browser-siteProtections.js:2271

I think this might be intermittent. This time I couldn't reproduce it using reddit.com, but I did reproduce the issue on dailymotion.com.
I hope this info will help.

Flags: needinfo?(oana.botisan)

Yes, that helps very much, thank you, it seems like this is a dupe of bug 1514246. I wonder if it's a good idea to keep showing the text in case of an error, though. Leaving this in triage to talk about it.

Thanks!

Has Regression Range: --- → yes

Hmm. From the duplicates here it may not be a new issue in 70.

FWIW we do not think that this should be tracked for 70, it's a small bug that should rarely occur.

The best solution here is probably not to just clear the input field but rather show an error message. We'll try to look into this.

Keywords: regression
Priority: -- → P3

Changing the priority to p1 as the bug is tracked by a release manager for the current beta.
See What Do You Triage for more information

Priority: P3 → P1

Too late to fix for 70 but we could still take a patch in 71/72.

Component: Site Identity → Protections UI
Flags: needinfo?(jhofmann)
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Flags: needinfo?(jhofmann)
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/13566afee847
Show an error message when content blocking breakage reporting fails. r=nhnt11,fluent-reviewers,flod

Backed out 3 changesets (bug 1582751, bug 1575785, bug 1592616) for failing at browser_protections_UI.js on a CLOSED TREE.

Backout link: https://hg.mozilla.org/integration/autoland/rev/f6d03ead730474725aa8f835b6b602f094764bc5

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&group_state=expanded&resultStatus=testfailed%2Cbusted%2Cexception&failure_classification_id=2&revision=4905af6536bdc0201385ccd677ea96a63ff67691&selectedJob=274104135

Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=274104135&repo=autoland&lineNumber=3133

Log snippet:

[task 2019-11-01T15:51:26.338Z] 15:51:26 INFO - TEST-START | browser/base/content/test/siteProtections/browser_protections_UI.js
[task 2019-11-01T15:51:26.496Z] 15:51:26 INFO - GECKO(1835) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /tmp/tmpMo5CVx.mozrunner/runtests_leaks_tab_pid1994.log
[task 2019-11-01T15:51:26.532Z] 15:51:26 INFO - GECKO(1835) | [Child 1994, Main Thread] WARNING: No CID found when attempting to map contract ID: file /builds/worker/workspace/build/src/xpcom/components/nsComponentManager.cpp, line 729
[task 2019-11-01T15:51:26.669Z] 15:51:26 INFO - GECKO(1835) | [Child 1909, Main Thread] WARNING: '!aWin', file /builds/worker/workspace/build/src/dom/base/Document.cpp, line 1386
[task 2019-11-01T15:51:26.669Z] 15:51:26 INFO - GECKO(1835) | [Child 1909, Main Thread] WARNING: '!aWin', file /builds/worker/workspace/build/src/dom/base/Document.cpp, line 1386
[task 2019-11-01T15:51:26.737Z] 15:51:26 INFO - GECKO(1835) | Couldn't convert chrome URL: chrome://branding/locale/brand.properties
[task 2019-11-01T15:51:26.858Z] 15:51:26 INFO - GECKO(1835) | [Child 1994, Main Thread] WARNING: could not set real-time limit at process startup: file /builds/worker/workspace/build/src/dom/ipc/ContentChild.cpp, line 1787
[task 2019-11-01T15:51:26.874Z] 15:51:26 INFO - GECKO(1835) | ++DOCSHELL 0x7f83815b6800 == 1 [pid = 1994] [id = {24642fa7-5138-44f0-a0ff-ee285ff3303c}]
[task 2019-11-01T15:51:26.915Z] 15:51:26 INFO - GECKO(1835) | ++DOMWINDOW == 1 (0x7f838249af20) [pid = 1994] [serial = 1] [outer = (nil)]
[task 2019-11-01T15:51:26.915Z] 15:51:26 INFO - GECKO(1835) | ++DOMWINDOW == 2 (0x7f8381571c00) [pid = 1994] [serial = 2] [outer = 0x7f838249af20]
[task 2019-11-01T15:51:27.198Z] 15:51:27 INFO - GECKO(1835) | ++DOMWINDOW == 3 (0x7f838240c800) [pid = 1994] [serial = 3] [outer = 0x7f838249af20]
[task 2019-11-01T15:51:27.415Z] 15:51:27 INFO - GECKO(1835) | [Parent 1835, Main Thread] WARNING: '!mPresContext', file /builds/worker/workspace/build/src/dom/events/UIEvent.cpp, line 136
[task 2019-11-01T15:51:27.416Z] 15:51:27 INFO - GECKO(1835) | [Parent 1835, Main Thread] WARNING: '!mPresContext', file /builds/worker/workspace/build/src/dom/events/UIEvent.cpp, line 150
[task 2019-11-01T15:51:27.645Z] 15:51:27 INFO - TEST-INFO | started process screentopng
[task 2019-11-01T15:51:28.071Z] 15:51:28 INFO - TEST-INFO | screentopng: exit 0
[task 2019-11-01T15:51:28.071Z] 15:51:28 INFO - Buffered messages logged at 15:51:26
[task 2019-11-01T15:51:28.072Z] 15:51:28 INFO - Entering test bound setup
[task 2019-11-01T15:51:28.072Z] 15:51:28 INFO - Leaving test bound setup
[task 2019-11-01T15:51:28.073Z] 15:51:28 INFO - Entering test bound testToggleSwitch
[task 2019-11-01T15:51:28.073Z] 15:51:28 INFO - Buffered messages logged at 15:51:27
[task 2019-11-01T15:51:28.074Z] 15:51:28 INFO - TEST-PASS | browser/base/content/test/siteProtections/browser_protections_UI.js | recorded telemetry for opening the popup -
[task 2019-11-01T15:51:28.074Z] 15:51:28 INFO - Buffered messages finished
[task 2019-11-01T15:51:28.075Z] 15:51:28 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/siteProtections/browser_protections_UI.js | The 'Site not working?' link should be visible. -
[task 2019-11-01T15:51:28.075Z] 15:51:28 INFO - Stack trace:
[task 2019-11-01T15:51:28.075Z] 15:51:28 INFO - chrome://mochikit/content/browser-test.js:test_ok:1299
[task 2019-11-01T15:51:28.076Z] 15:51:28 INFO - chrome://mochitests/content/browser/browser/base/content/test/siteProtections/browser_protections_UI.js:testToggleSwitch:52
[task 2019-11-01T15:51:28.077Z] 15:51:28 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1069
[task 2019-11-01T15:51:28.078Z] 15:51:28 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1104
[task 2019-11-01T15:51:28.079Z] 15:51:28 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:932
[task 2019-11-01T15:51:28.080Z] 15:51:28 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:805

Flags: needinfo?(jhofmann)
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/be51af34cb7a
Show an error message when content blocking breakage reporting fails. r=nhnt11,fluent-reviewers,flod
Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0de7d040e6d1
Backed out 3 changesets (bug 1582751, bug 1575785, bug 1592616) for causing perma failures in browser/base/content/test/siteProtections/browser_protections_UI.js CLOSED TREE
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/7870976299f2
Show an error message when content blocking breakage reporting fails. r=nhnt11,fluent-reviewers,flod
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/fadcc9e29ffd
Show an error message when content blocking breakage reporting fails. r=nhnt11,fluent-reviewers,flod
Backout by rgurzau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/db7fb8a98e5a
Backed out 5 changesets (bug 1582751, bug 1575785, bug 1592616) for failing at browser_protections_UI.js on a CLOSED TREE.

Backed out 5 changesets (bug 1582751, bug 1575785, bug 1592616) for failing at browser_protections_UI.js on a CLOSED TREE.

Backout link: https://hg.mozilla.org/integration/autoland/rev/db7fb8a98e5aadc3581cfdaa8dc23b4fa2fbaeb7

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&tochange=b4ef304c1c6ba4ae9dcce9eddb14cdfe98ccf871&fromchange=ee2ba98f5a17a17cb493790ac3439ff96b9772e3&selectedJob=274813274

Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=274813274&repo=autoland&lineNumber=7031

Log snippet:

[task 2019-11-06T12:46:37.410Z] 12:46:37 INFO - TEST-INFO | started process screentopng
[task 2019-11-06T12:46:37.817Z] 12:46:37 INFO - TEST-INFO | screentopng: exit 0
[task 2019-11-06T12:46:37.817Z] 12:46:37 INFO - Buffered messages logged at 12:46:30
[task 2019-11-06T12:46:37.817Z] 12:46:37 INFO - Entering test bound setup
[task 2019-11-06T12:46:37.818Z] 12:46:37 INFO - Leaving test bound setup
[task 2019-11-06T12:46:37.818Z] 12:46:37 INFO - Entering test bound testToggleSwitch
[task 2019-11-06T12:46:37.819Z] 12:46:37 INFO - Buffered messages logged at 12:46:32
[task 2019-11-06T12:46:37.819Z] 12:46:37 INFO - Console message: [JavaScript Warning: "The resource at “http://trackertest.org/” was blocked because content blocking is enabled." {file: "about:blank" line: 0}]
[task 2019-11-06T12:46:37.821Z] 12:46:37 INFO - Buffered messages finished
[task 2019-11-06T12:46:37.822Z] 12:46:37 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/siteProtections/browser_protections_UI.js | Uncaught exception - undefined - timed out after 50 tries.
[task 2019-11-06T12:46:37.823Z] 12:46:37 INFO - Leaving test bound testToggleSwitch
[task 2019-11-06T12:46:37.824Z] 12:46:37 INFO - Entering test bound testSettingsButton
[task 2019-11-06T12:46:37.825Z] 12:46:37 INFO - GECKO(4310) | ### XPCOM_MEM_BLOAT_LOG defined

Flags: needinfo?(agakhokidze)

I am not sure why I was NI'd on this? Can you please explain this a bit more?

Flags: needinfo?(rgurzau)

This was about Bug 1592616 being backed out for having the above mentioned failure but i backed out the whole push which contained 3 bugs. Please let me know if i should reland any of them.

Flags: needinfo?(rgurzau)

But that bug is not related to me either.. Unless I am missing something :)

Flags: needinfo?(rgurzau)

You are right. It's a misunderstanding, sorry for the confusion.

Flags: needinfo?(rgurzau)
Flags: needinfo?(agakhokidze)
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e8ba7d342c46
Show an error message when content blocking breakage reporting fails. r=nhnt11,fluent-reviewers,flod
Backout by ccoroiu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5991f81dbc95
Backed out 5 changesets (bug 1582751, bug 1575785, bug 1592616) for browser-chrome failures at browser/base/content/test/siteProtections/browser_protections_UI.js on a CLOSED TREE
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a9d488141dde
Show an error message when content blocking breakage reporting fails. r=nhnt11,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Flags: qe-verify+
Flags: needinfo?(jhofmann)

Hi, This issue is Verified as fixed in our latest Release build 72.0.2, on Windows 10, Mac 10.13 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.