Closed Bug 1582797 Opened 2 years ago Closed 2 years ago

OverflowableToolbar should respond to resize events immediately

Categories

(Firefox :: Toolbars and Customization, defect, P1)

defect
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 71
Tracking Status
firefox71 --- fixed

People

(Reporter: dao, Assigned: dao)

References

(Regressed 2 open bugs)

Details

(Keywords: perf)

Attachments

(1 file)

OverflowableToolbar currently responds to resize events with a 200ms delay after the last resize event. Since we don't flush layout to detect overflow, this isn't a useful performance optimization. Before bug 1580538 we could at least get an overflow or underflow event while resizing, now we depend solely on resize. This makes Firefox look laggy while resizing. It also unnecessarily complicates the code.

Blocks: 1468890
Priority: -- → P1
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/714d667c7f12
OverflowableToolbar should respond to resize events immediately. r=Gijs
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Regressions: 1609398
Regressions: 1712735
You need to log in before you can comment on or make changes to this bug.