bad request error (iPlanet Web Server needed upgrade)

VERIFIED INVALID

Status

()

Core
Networking: HTTP
VERIFIED INVALID
16 years ago
15 years ago

People

(Reporter: Peter Jamieson, Assigned: Darin Fisher)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002020516

I am requesting a frameset and frames from an iPlanet 4 web server and a bad
request occurs.
If i truss the browser, the fault goes away which leads me to believe that it's
a timing issue (doesn't happen in netscape 6)
I managed to get a truss trace by trussing the browser and the web server.

Reproducible: Always
Steps to Reproduce:
1. Is caused by calling a JSP which is not public but i will attach a truss of
the fault for investigation.

Actual Results:  I got a bad request in one of the frames

Expected Results:  It seems that the fault is partially with the web server for
sending the "bad request" message but it has no header information so mozilla
should not display it.
(Reporter)

Comment 1

16 years ago
Created attachment 91941 [details]
Truss of the fault occuring

This is a truss of the browser taken when the fault occurs
(Reporter)

Comment 2

16 years ago
Created attachment 91942 [details]
Truss of the webserver

This is a truss taken of the web server when the fault occurs
truss output is basically useless for debugging this sort of problem.

IF you suspect an HTTP problem, then setting the env variables:

NSPR_LOG_MODULES=nsHttp:5
NSPR_LOG_FILE=bug158293.log

and then running mozilla on those pages will produce a log file. IF you attach
that, then it could be used ot help track this down.

HAve you enabled pipelining, perhaps?
Assignee: new-network-bugs → darin
Component: Networking → Networking: HTTP
QA Contact: benc → tever
(Reporter)

Comment 4

16 years ago
Do i need a debug build for this to work.
I tried it and couldn't find any log file.
(Reporter)

Comment 5

16 years ago
Created attachment 91956 [details]
mozilla log file

The logging from mozilla of the fault occurring
(Reporter)

Comment 6

16 years ago
line 516 of the truss (timestamp 2.3227) shows that the post is being sent in 2
chunks.  This is being read by the webserver as 2 requests and causing the fault.

Why is the request being sent in 2 chunks?
(Assignee)

Comment 7

16 years ago
then the webserver is probably at fault.  TCP/IP allows data packets to be
divided into smaller packets, so there is never any guarantee about the number
of packets that will be sent.
(Assignee)

Comment 8

16 years ago
any chance you could provide a packet trace corresponding to the "bad request" ?
(Reporter)

Comment 9

16 years ago
The web server is definately at fault.

Apparently an HTTP 1.1 thing that requests can be chunked (according to iPlanet
webserver release notes) and this was a new feature added to the web server.

Installed a service pack for the server and the problem miraculously dissappeared.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 10

15 years ago
Verified invalid.
Status: RESOLVED → VERIFIED
QA Contact: tever → junruh

Updated

15 years ago
Summary: bad request caused by timing issue. → bad request error (iPlanet Web Server needed upgrade)
You need to log in before you can comment on or make changes to this bug.