Closed Bug 1582972 Opened 4 months ago Closed 4 months ago

Perma tier2 WindowsError: [Error 216] This version of %1 is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher

Categories

(Testing :: XPCShell Harness, defect, P5)

Version 3
defect

Tracking

(firefox-esr60 unaffected, firefox-esr68 unaffected, firefox69 unaffected, firefox70 unaffected, firefox71 fixed)

RESOLVED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: glandium)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: nerli [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=267643991&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/S4ocjo0wSaSuxdZAeP6gTA/runs/0/artifacts/public/logs/live_backing.log


[task 2019-09-20T15:27:37.740Z] 15:27:37 INFO - Calling ['C:\tasks\task_1568988503\build\venv\Scripts\python', '-u', 'C:\tasks\task_1568988503\build\tests\xpcshell\runxpcshelltests.py', '--total-chunks', '3', '--this-chunk', '1', '--setpref=media.peerconnection.mtransport_process=false', '--setpref=network.process.enabled=false', u'--symbols-path=https://queue.taskcluster.net/v1/task/Sx3Rntt7QjGeuG6wWA0ltQ/artifacts/public/build/target.crashreporter-symbols.zip', '--test-plugin-path=C:\tasks\task_1568988503\build\application\firefox\plugins', '--log-raw=C:\tasks\task_1568988503\build\blobber_upload_dir\xpcshell_raw.log', '--log-errorsummary=C:\tasks\task_1568988503\build\blobber_upload_dir\xpcshell_errorsummary.log', '--utility-path=tests/bin', '--xpcshell=C:\tasks\task_1568988503\build\application\firefox/xpcshell.exe', '--manifest=tests/xpcshell/tests/xpcshell.ini'] with output_timeout 1000
[task 2019-09-20T15:27:38.652Z] 15:27:38 INFO - Found node at C:/tasks/task_1568988503/fetches\node/node.exe
[task 2019-09-20T15:27:38.652Z] 15:27:38 INFO - Found moz-http2 at C:\tasks\task_1568988503\build\tests\xpcshell\moz-http2\moz-http2.js
[task 2019-09-20T15:27:38.672Z] 15:27:38 INFO - Could not run moz-http2 server: [Error 216] This version of %1 is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher
[task 2019-09-20T15:27:38.672Z] 15:27:38 INFO - Traceback (most recent call last):
[task 2019-09-20T15:27:38.672Z] 15:27:38 INFO - File "C:\tasks\task_1568988503\build\tests\xpcshell\runxpcshelltests.py", line 1689, in <module>
[task 2019-09-20T15:27:38.674Z] 15:27:38 INFO - main()
[task 2019-09-20T15:27:38.674Z] 15:27:38 INFO - File "C:\tasks\task_1568988503\build\tests\xpcshell\runxpcshelltests.py", line 1684, in main
[task 2019-09-20T15:27:38.684Z] 15:27:38 INFO - if not xpcsh.runTests(options):
[task 2019-09-20T15:27:38.684Z] 15:27:38 INFO - File "C:\tasks\task_1568988503\build\tests\xpcshell\runxpcshelltests.py", line 1343, in runTests
[task 2019-09-20T15:27:38.689Z] 15:27:38 INFO - self.trySetupNode()
[task 2019-09-20T15:27:38.689Z] 15:27:38 INFO - File "C:\tasks\task_1568988503\build\tests\xpcshell\runxpcshelltests.py", line 1157, in trySetupNode
[task 2019-09-20T15:27:38.694Z] 15:27:38 INFO - startServer('moz-http2', os.path.join(myDir, 'moz-http2', 'moz-http2.js'))
[task 2019-09-20T15:27:38.694Z] 15:27:38 INFO - File "C:\tasks\task_1568988503\build\tests\xpcshell\runxpcshelltests.py", line 1139, in startServer
[task 2019-09-20T15:27:38.699Z] 15:27:38 INFO - stderr=PIPE, env=self.env, cwd=os.getcwd())
[task 2019-09-20T15:27:38.699Z] 15:27:38 INFO - File "c:\mozilla-build\python\Lib\subprocess.py", line 710, in init
[task 2019-09-20T15:27:38.704Z] 15:27:38 INFO - errread, errwrite)
[task 2019-09-20T15:27:38.704Z] 15:27:38 INFO - File "c:\mozilla-build\python\Lib\subprocess.py", line 958, in _execute_child
[task 2019-09-20T15:27:38.706Z] 15:27:38 INFO - startupinfo)
[task 2019-09-20T15:27:38.706Z] 15:27:38 INFO - WindowsError: [Error 216] This version of %1 is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher
[task 2019-09-20T15:27:38.754Z] 15:27:38 ERROR - Return code: 1
[task 2019-09-20T15:27:38.754Z] 15:27:38 ERROR - No tests run or test summary not found
[task 2019-09-20T15:27:38.754Z] 15:27:38 INFO - TinderboxPrint: xpcshell-xpcshell<br/><em class="testfail">T-FAIL</em>
[task 2019-09-20T15:27:38.755Z] 15:27:38 WARNING - # TBPL FAILURE #
[task 2019-09-20T15:27:38.755Z] 15:27:38 WARNING - setting return code to 2
[task 2019-09-20T15:27:38.755Z] 15:27:38 WARNING - The xpcshell suite: xpcshell ran with return status: FAILURE
[task 2019-09-20T15:27:38.755Z] 15:27:38 INFO - Running post-action listener: _package_coverage_data
[task 2019-09-20T15:27:38.755Z] 15:27:38 INFO - Running post-action listener: _resource_record_post_action
[task 2019-09-20T15:27:38.756Z] 15:27:38 INFO - Running post-action listener: process_java_coverage_data
[task 2019-09-20T15:27:38.756Z] 15:27:38 INFO - [mozharness: 2019-09-20 15:27:38.756000Z] Finished run-tests step (success)
[task 2019-09-20T15:27:38.756Z] 15:27:38 INFO - Running post-run listener: _resource_record_post_run

Summary: Intermittent WindowsError: [Error 216] This version of %1 is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher → Perma tier2 WindowsError: [Error 216] This version of %1 is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher
Regressed by: 1578963

:junior - I don't see any node configuration difference between x86 and aarch64 windows. Do we need a windows aarch64 version of node?

Flags: needinfo?(juhsu)

(In reply to Geoff Brown [:gbrown] from comment #4)

:junior - I don't see any node configuration difference between x86 and aarch64 windows. Do we need a windows aarch64 version of node?

We should, but I have no idea why it works previously.
AFAICT we didn't have a specific version of node when we used tooltool before bug 1571573.
Looks like there's another path to grab nodejs I didn't figure out

Flags: needinfo?(juhsu)

I don't know why win32 works for aarch64 and win64 before for testing...

https://treeherder.mozilla.org/#/jobs?repo=autoland&group_state=expanded&revision=8b50000b89ddcc8ebb0a259f481e1d2459026839&selectedJob=268027574

21:38:50 INFO - INFO - File node-win32.exe retrieved from local cache C:\tooltool-cache
21:38:50 INFO - Return code: 0
21:38:50 INFO - ENV: MOZ_NODE_PATH is now C:\tasks\task_1569272394\build\node-win32.exe

..

21:38:51 INFO - Found node at C:\tasks\task_1569272394\build\node-win32.exe
21:38:51 INFO - Found moz-http2 at C:\tasks\task_1569272394\build\tests\xpcshell\moz-http2\moz-http2.js

Mike can you take a look?

Flags: needinfo?(mh+mozilla)
Assignee: nobody → mh+mozilla
Flags: needinfo?(mh+mozilla)

Bug 1571573 removed the manual download of node by mozharness. That made
the tasks use whatever comes from fetches, and for aarch64 tests, it
turned out to be a win64 node binary, which doesn't work on aarch64.

Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/345d89faf40e
Use win32-node for aarch64 tests. r=nalexander
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

There have been 45 failures in the last 7 days.

Affected platform is: windows10-aarch64 opt.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=269172272&repo=mozilla-central&lineNumber=1024

Flags: needinfo?(mh+mozilla)

There have been no failures since the fix landed, on Sept 30; no follow-up is needed.

Flags: needinfo?(mh+mozilla)
You need to log in before you can comment on or make changes to this bug.