Closed Bug 1583043 Opened 5 months ago Closed 5 months ago

toolkit/components/passwordmgr/test/browser/browser_entry_point_telemetry.js | content must be in snapshot. Has []. - false == true - JS frame :: resource://testing-common/TelemetryTestUtils.jsm :: assertEvents :: line 138

Categories

(Toolkit :: Password Manager, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed
firefox71 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: MattN)

References

(Depends on 1 open bug)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Summary: TV toolkit/components/passwordmgr/test/browser/browser_entry_point_telemetry.js | content must be in snapshot. Has []. - false == true - JS frame :: resource://testing-common/TelemetryTestUtils.jsm :: assertEvents :: line 138 → toolkit/components/passwordmgr/test/browser/browser_entry_point_telemetry.js | content must be in snapshot. Has []. - false == true - JS frame :: resource://testing-common/TelemetryTestUtils.jsm :: assertEvents :: line 138

Matt, could you please take a look over this? It has quite a spike since it was filled. https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-09-16&endday=2019-09-23&tree=trunk&bug=1583043

Flags: needinfo?(MattN+bmo)
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(MattN+bmo)
Priority: P5 → P1
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/dc5363b6f314
Wait for telemetry events before asserting in browser_entry_point_telemetry. r=jaws
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Regressions: 1584148

Comment on attachment 9095208 [details]
Bug 1583043 - Wait for telemetry events before asserting in browser_entry_point_telemetry. r=jaws

(In reply to Andreea Pavel [:apavel] from comment #9)

This shows up on beta: https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&selectedJob=268498722&resultStatus=testfailed%2Cbusted%2Cexception should the fix be uplifted?

I don't know why beta failures don't show at https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-09-19&endday=2019-09-26&tree=trunk&bug=1583043

Beta/Release Uplift Approval Request

  • User impact if declined: Test-only intermittent failure fix
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Test-only change to reduce intermittent frequency.
  • String changes made/needed: None
Flags: needinfo?(MattN+bmo)
Attachment #9095208 - Flags: approval-mozilla-beta?
Blocks: 1550631
No longer blocks: 155063
No longer blocks: 1584148
Depends on: 1584148
No longer regressions: 1584148

Comment on attachment 9095208 [details]
Bug 1583043 - Wait for telemetry events before asserting in browser_entry_point_telemetry. r=jaws

test-only changes don't need approval, but here it is anyway :)

Attachment #9095208 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

(In reply to Matthew N. [:MattN] (PM me if requests are blocking you) from comment #11)

Comment on attachment 9095208 [details]
Bug 1583043 - Wait for telemetry events before asserting in browser_entry_point_telemetry. r=jaws

(In reply to Andreea Pavel [:apavel] from comment #9)

This shows up on beta: https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&selectedJob=268498722&resultStatus=testfailed%2Cbusted%2Cexception should the fix be uplifted?

I don't know why beta failures don't show at https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-09-19&endday=2019-09-26&tree=trunk&bug=1583043

They don't show up because in the above link tree=trunk. If you switch to tree=all the beta failures should show up.

You need to log in before you can comment on or make changes to this bug.