Authors item in Links Toolbar / Site Navigation Toolbar should read Author(s)

RESOLVED FIXED

Status

defect
--
trivial
RESOLVED FIXED
17 years ago
11 years ago

People

(Reporter: mxn, Assigned: choess)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020719
BuildID:    20020719

The Links Toolbar, aka Site Navigation Toolbar, has an item under the More menu that reads "Authors". It should read "Author(s)", because some websites that utilize the Links Toolbar have only one author.

Reproducible: Always

Steps to Reproduce:
1. Open Mozilla.
2. Go to a website that has only one author. You can try my website, http://mxn.netfirms.com/ .
3. The Links Toolbar should appear, if it doesn't, go to View | Show/Hide | Site Navigation Bar | Show Only As Needed.
4. Click on the More menu in the Links Toolbar.

Actual Results:  
Third menu item reads "Authors".

Expected Results:  
Third menu should read "Author(s)".

Using English (US) language pack.

Comment 1

17 years ago
Confirmed 2002071508.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

17 years ago
To self.
Assignee: blaker → choess
Status: ASSIGNED → NEW

Comment 3

17 years ago
Adding to fixable with patchmaker list.
Blocks: patchmaker

Comment 4

17 years ago
This fixes the reported issue, but in the same file there are plenty of other
possible "fixes" such as pages with only one other version, with one bookmark,
or with one section, subsection, appendix, or chapter. I don't think it would
look good to change them all--we don't want to have too many (s) in the menus,
and also Appendix would be weird. But since this is the only one that isn't a
submenu, I think it should be the only one changed.
(Reporter)

Comment 5

17 years ago
I don't think it's necessary to change the chaper, section, etc. menuitems,
because it'll be obvious as to whether there is one chapter, section, etc., just
by hovering over those items and waiting for the submenu to pop out. But it
might not be so easy to find out the number of authors.

Updated

17 years ago
Keywords: patch, review
(Assignee)

Comment 6

17 years ago
Comment on attachment 95223 [details] [diff] [review]
Change Authors to Author(s)

r=choess
Attachment #95223 - Flags: review+
(Assignee)

Updated

17 years ago
Attachment #95223 - Flags: superreview?(jaggernaut)

Comment 7

17 years ago
Comment on attachment 95223 [details] [diff] [review]
Change Authors to Author(s)

sr=jag
Attachment #95223 - Flags: superreview?(jaggernaut) → superreview+
(Assignee)

Comment 8

16 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
No longer blocks: patchmaker
Product: Core → Mozilla Application Suite

Updated

11 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.