Closed Bug 1583091 Opened 6 months ago Closed 6 months ago

async-scrollbar-* tests are not drawing the scrollbars on mac + WR

Categories

(Core :: Graphics: WebRender, defect, P2)

x86_64
macOS
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: gw, Unassigned)

References

Details

(Keywords: regression)

They started to fail intermittently with the snapping changes (see https://bugzilla.mozilla.org/show_bug.cgi?id=1581878).

This refactoring patch https://phabricator.services.mozilla.com/D46125 has made them permanently PASS, but that's because the scrollbars don't draw at all so the images are equal.

I confirmed that they still fail to draw, even with picture caching completely disabled, which rules out any changes in the refactoring patch above. I also rebased my patch prior to the snapping changes, and the scrollbars were drawing correctly.

Maybe bug 1581934 fixes this.

Has Regression Range: --- → yes
Flags: needinfo?(aosmond)
Keywords: regression
OS: Unspecified → macOS
Priority: -- → P2
Regressions: wr-snapperific
Hardware: Unspecified → x86_64

So, just to make sure I'm understanding this:

Did I get that right?

I worked out what's going on - the changes I'm making in https://phabricator.services.mozilla.com/D46125 expose a pre-existing bug in WR related to the clipping stack. So it's unrelated to the snapping changes in https://bugzilla.mozilla.org/show_bug.cgi?id=1581878, they just tripped me up in working out what is going on, since they affect the same set of tests.

Status: NEW → RESOLVED
Closed: 6 months ago
Flags: needinfo?(aosmond)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.