Closed Bug 1583170 Opened 4 months ago Closed 4 months ago

The Network ID field is not populated

Categories

(Core :: Networking, defect, P1, blocker)

71 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 + verified
firefox71 --- verified

People

(Reporter: bsurd, Assigned: valentin)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [necko-triaged])

Attachments

(2 files)

Attached image networkID.png

Affected versions:

  • Firefox Release 70.0b8 and above

Affected Platforms:

  • Windows 10 (64-bit)
  • Mac 10.14

Prerequisites:

  • You are connected to any network.

Steps to reproduce:

  1. Open Firefox and go to about:networking#networkid.
  2. Observe the Network ID field.

Expected result:

  • The Network ID has a value displayed.

Actual result:

  • There is no value in the Network ID field.

Notes:
The issue is not reproducible on Linux. Only Windows and Mac seems to be affected.

For Mac I was not able to find a regression since it seems to be affected from the initial implementation of this, tried a variety of ranges:

  • all builds between 2019-08-02 to 2019-08-17
  • all builds between 2019-09-15 to 2019-09-23

The Network ID was not displayed for any of these builds.

Here are the results of a Mozregression ran on WIndows 10
Last good revision: 2591b1d2429d5ac5afb3a98e5d19e7499e70dd4d
First bad revision: d17822726031d339cbaf099fd59e4bc69fb9e389
Pushlog: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=2591b1d2429d5ac5afb3a98e5d19e7499e70dd4d&tochange=d17822726031d339cbaf099fd59e4bc69fb9e389

Valentin, could you look into the regression, which seems to have been introduced by your change (see previous comment)? Thanks!

Flags: needinfo?(valentin.gosu)

Tracking since this is needed for a Skyline feature in 70.

Assignee: nobody → valentin.gosu
Priority: -- → P1
Whiteboard: [necko-triaged]
Flags: needinfo?(valentin.gosu)
Regressed by: 1576386

Bug 1576386 converted the thread into a threadpool, but when changing that it failed to dispatch the runnable to the thread/threadpool as before.
As a result nsNotifyAddrListener stopped listening for network change events on windows.

(Did no go through either of the bugs - bug could this be related to Bug 1583204?)

Flags: needinfo?(valentin.gosu)

(In reply to Honza Bambas (:mayhemer) from comment #4)

(Did no go through either of the bugs - bug could this be related to Bug 1583204?)

Doesn't look like it. This bug is windows only.

Flags: needinfo?(valentin.gosu)
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/da073603985f
Dispatch nsNotifyAddrListener runnable after creating thread r=michal
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

Please nominate this for Beta uplift when you get a chance.

Flags: needinfo?(valentin.gosu)

Comment on attachment 9094880 [details]
Bug 1583170 - Dispatch nsNotifyAddrListener runnable after creating thread r=mayhemer

Beta/Release Uplift Approval Request

  • User impact if declined: network change events are not detected and networkID is not computed.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: see comment 0
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Fixes issue introduced in bug 1576386 where event was not dispatched to the newly created thread.
  • String changes made/needed:
Flags: needinfo?(valentin.gosu)
Attachment #9094880 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9094880 [details]
Bug 1583170 - Dispatch nsNotifyAddrListener runnable after creating thread r=mayhemer

Fix for new regression in 70, needed for skyline.
OK for uplift for beta 11.

Attachment #9094880 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

This has been verified with the latest nightly. Any other issues encountered have been filed separately. Adding a NI for myself to check after it lands in Beta.

Flags: needinfo?(bogdan.surd)

This has been verified in beta as well. No other issues have been found while testing this.

Status: RESOLVED → VERIFIED
Flags: needinfo?(bogdan.surd)
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.