Closed Bug 1583179 Opened 3 years ago Closed 2 months ago

Browser toolbox - empty page on refresh from Network tool with internal page open in another tab

Categories

(DevTools :: Netmonitor, defect, P2)

defect

Tracking

(firefox-esr60 wontfix, firefox-esr68 wontfix, firefox69 wontfix, firefox70 wontfix, firefox71 wontfix, firefox103 verified)

VERIFIED FIXED
103 Branch
Tracking Status
firefox-esr60 --- wontfix
firefox-esr68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- wontfix
firefox103 --- verified

People

(Reporter: cfogel, Assigned: bomsy)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Affected versions
*60.9esr, 68.1.0esr, 69.0.1, 70.0b8, 71.0a1 (2019-09-22) ;

Affected platforms

  • Windows 10, macOS 10.14;

Steps to reproduce

  • Enable: Enable browser chrome and add-on debugging toolboxes, Enable remote debugging;
  1. Launch Firefox, enable the DevTools inspector;
  2. Access any internal about: page (*ex: about:about or about:config)
  3. Open a new tab and access any webpage in it;
  4. Enable the Browser Toolbox;
  5. Access the Network tab;
  6. Click inside the empty Network tab to trigger the page reload;

Expected result

  • page reloads properly, Network tab is aggregated with information;

Actual result

  • page goes blank, back/forward buttons are disabled;

Regression range

  • regression range might be invalid since with builds prior to the one considered "good" the Refresh button had no effect;
  • First bad: changeset: 43fb1f92e8d4 build_date: 2015-03-07
  • Last good: changeset: 0189941a3fd5 build_date: 2015-03-06
  • Pushlog URL

Additional notes

  • attached recording with the issue;
  • issue does not reproduce for browser console;
  • marked the issue with minor priority since it's somewhat of an edge case scenario.
Has Regression Range: --- → yes
Has STR: --- → yes

Thanks for the report!

I can easily reproduce on my machine, Win10

Honza

Priority: -- → P2

Some pointers to the source code:

  1. Here is the place where we handle the user action (clicking on the reload button)
    https://searchfox.org/mozilla-central/rev/153feabebc2d13bb4c29ef8adf104ec1ebd246ae/devtools/client/netmonitor/src/components/RequestListEmptyNotice.js#91

  2. Here is the place where Net panel connector calls: this.tabTarget.reconfigure
    https://searchfox.org/mozilla-central/rev/153feabebc2d13bb4c29ef8adf104ec1ebd246ae/devtools/client/netmonitor/src/connector/firefox-connector.js#345-357

  3. Here is the backend piece that is triggered by the client side:
    https://searchfox.org/mozilla-central/rev/153feabebc2d13bb4c29ef8adf104ec1ebd246ae/devtools/shared/fronts/targets/browsing-context.js#120-127

I am seeing expected value in the options object:
{"performReload":true}

Not sure what super object is executed in this case.
But, it looks like that the entire browser window is reloaded in the end?

Alex, any tips here?

Honza

Flags: needinfo?(poirot.alex)

The pushlog is from 2015:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0189941a3fd5&tochange=fecf1afb0830

This isn't a regression but the expected behavior of the "Browser toolbox". The browser toolbox debugs Firefox itself, so we expect it to target Firefox and not only one given of its tab.

Flags: needinfo?(poirot.alex)

Now, if there is an issue with this behavior, we can tweak it. But that would be a feature request and we should better understand what are your expectation against the Browser toolbox.
If you can about only one tab network requests, Browser toolbox is probably not the right tool to inspect them.

Not a regression, adjusting tracking flags and keyword.

Has Regression Range: yes → ---
Keywords: regression

let's remove the buttons in the Browser Toolbox, as it doesn't make too much sense in that context

Assignee: nobody → hmanilla
Status: NEW → ASSIGNED
Pushed by hmanilla@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e86098a5b60d
[devtools] Remove the reload and analyze performance buttons in the browser toolbox r=nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 103 Branch
Regressions: 1775295
No longer regressions: 1775295
Duplicate of this bug: 1293144
QA Whiteboard: [qa-103b-p2]

I managed to reproduce this issue on Firefox 102.0(build ID: 20220623063721) on Windows 10 64-bits. Verified as fixed on Firefox 103.0b6(build ID: 20220707185904) and Nightly 104.0a1(build ID: 20220707214915) on Windows 10 64-bits, macOS 12 and Ubuntu 22.04.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-103b-p2]
You need to log in before you can comment on or make changes to this bug.