Closed Bug 1583234 Opened 2 months ago Closed Last month

./mach build w/ android artifact build fails w/ "ValueError: invalid literal for int() with base 10: '@ 494744'" on macOS

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox71 fixed)

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: mjf, Assigned: chmanchester)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

Attached file mjf_machoutput.txt

Running an Android artifact build w/ the default suggested .mozconfig fails w/ "ValueError: invalid literal for int() with base 10: '@ 494744'"

What is the output of hg log --template '{rev}:{node}\n' -r 'last(public) and ::., {500})' for you?

Flags: needinfo?(mfroman)
MJF-MacBookPro:moz-central mfroman$ hg log --template '{rev}:{node}\n' -r 'last(public) and ::., {500})'
hg: parse error at 22: syntax error in revset 'last(public) and ::., {500})'
(last(public) and ::., {500})
                       ^ here)

I ran ./mach vcs-setup --update and got the same error message

Flags: needinfo?(mfroman)

Here is the output from hg log --template '{rev}:{node}\n' -r 'last(public() and ::., 500)'

Output for the command: env HGPLAIN=1 hg log --template '{rev}:{node}\n' -r 'last(public() and ::., 500)'

The problem is that when we're trying to find a pushhead for artifact builds:

https://searchfox.org/mozilla-central/source/python/mozbuild/mozbuild/artifacts.py#968-975

we're not properly invoking hg with HGPLAIN=1, so we get extensions, aliases, etc. interfering with the expected output.

There are a couple other instances of hg log in this file that probably need to be addressed, too. Bootstrap handles this, but it handles it in kind of a bootstrap-specific way, so I'm not sure if there's much to be done here beyond duplicating the necessary code.

Assignee: nobody → cmanchester

I wrote a patch to set HGPLAIN, but I'm having trouble reproducing the issue to test. Comment 3 makes it looks like --graph is being passed to log by default, :mjf, have you made this the default in your hgrc? If so it looks like we can pass --no-graph as well during an artifact build.

Flags: needinfo?(mfroman)

:chmanchester, I have log aliased to "log -G" in my .hgrc file.

Flags: needinfo?(mfroman)
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/45f760e2a4c1
Set HGPLAIN when running hg during an artifact build. r=nalexander
Flags: needinfo?(cmanchester)
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e72742f591f8
Set HGPLAIN when running hg during an artifact build. r=nalexander
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Regressions: 1585258

I can confirm a successful artifact build on macOS.

You need to log in before you can comment on or make changes to this bug.