Closed Bug 1583241 Opened 1 year ago Closed 2 months ago

Intermittent browser/components/uitour/test/browser_UITour_detach_tab.js | Timeout waiting for visibility: old window highlight -

Categories

(Firefox :: Tours, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 80
Fission Milestone M4.1
Tracking Status
firefox80 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: apavel)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=267938398&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/ccRHxRmpRWOVkZ1DlG8Jrw/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/ccRHxRmpRWOVkZ1DlG8Jrw/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


[task 2019-09-23T11:25:42.796Z] 11:25:42 INFO - TEST-START | browser/components/uitour/test/browser_UITour_detach_tab.js
[task 2019-09-23T11:25:49.088Z] 11:25:49 INFO - TEST-INFO | started process screencapture
[task 2019-09-23T11:25:49.357Z] 11:25:49 INFO - TEST-INFO | screencapture: exit 0
[task 2019-09-23T11:25:49.358Z] 11:25:49 INFO - Buffered messages logged at 11:25:42
[task 2019-09-23T11:25:49.358Z] 11:25:49 INFO - Starting
[task 2019-09-23T11:25:49.358Z] 11:25:49 INFO - Buffered messages logged at 11:25:43
[task 2019-09-23T11:25:49.358Z] 11:25:49 INFO - test_move_tab_to_new_window
[task 2019-09-23T11:25:49.358Z] 11:25:49 INFO - Buffered messages finished
[task 2019-09-23T11:25:49.358Z] 11:25:49 INFO - TEST-UNEXPECTED-FAIL | browser/components/uitour/test/browser_UITour_detach_tab.js | Timeout waiting for visibility: old window highlight -
[task 2019-09-23T11:25:49.358Z] 11:25:49 INFO - Stack trace:
[task 2019-09-23T11:25:49.358Z] 11:25:49 INFO - chrome://mochikit/content/browser-test.js:test_ok:1580
[task 2019-09-23T11:25:49.358Z] 11:25:49 INFO - chrome://mochitests/content/browser/browser/components/uitour/test/head.js:taskify/</<:61
[task 2019-09-23T11:25:49.359Z] 11:25:49 INFO - promise callbackchrome://mochitests/content/browser/browser/components/uitour/test/head.js:taskify/<:60
[task 2019-09-23T11:25:49.359Z] 11:25:49 INFO - chrome://mochitests/content/browser/browser/components/uitour/test/head.js:nextTest/</<:546
[task 2019-09-23T11:25:49.359Z] 11:25:49 INFO - setTimeout handler
chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest_setTimeoutShim:686
[task 2019-09-23T11:25:49.359Z] 11:25:49 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:waitTest:909
[task 2019-09-23T11:25:49.359Z] 11:25:49 INFO - MessageListener.receiveMessagechrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus:906
[task 2019-09-23T11:25:49.359Z] 11:25:49 INFO - chrome://mochikit/content/browser-test.js:test_waitForFocus:1661
[task 2019-09-23T11:25:49.359Z] 11:25:49 INFO - chrome://mochitests/content/browser/browser/components/uitour/test/head.js:loadUITourTestPage/<:441
[task 2019-09-23T11:25:49.359Z] 11:25:49 INFO - promise callback
chrome://mochitests/content/browser/browser/components/uitour/test/head.js:loadUITourTestPage:325
[task 2019-09-23T11:25:49.359Z] 11:25:49 INFO - chrome://mochitests/content/browser/browser/components/uitour/test/head.js:nextTest/<:545
[task 2019-09-23T11:25:49.359Z] 11:25:49 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:805
[task 2019-09-23T11:25:49.359Z] 11:25:49 INFO - == Done test, doing shared checks before teardown ==
[task 2019-09-23T11:25:49.359Z] 11:25:49 INFO - TEST-PASS | browser/components/uitour/test/browser_UITour_detach_tab.js | Element should not be null, when checking visibility -
[task 2019-09-23T11:25:49.359Z] 11:25:49 INFO - TEST-PASS | browser/components/uitour/test/browser_UITour_detach_tab.js | Highlight should be closed/hidden after UITour tab is closed -
[task 2019-09-23T11:25:49.360Z] 11:25:49 INFO - TEST-PASS | browser/components/uitour/test/browser_UITour_detach_tab.js | Element should not be null, when checking visibility -
[task 2019-09-23T11:25:49.360Z] 11:25:49 INFO - TEST-PASS | browser/components/uitour/test/browser_UITour_detach_tab.js | Tooltip should be closed/hidden after UITour tab is closed -
[task 2019-09-23T11:25:49.360Z] 11:25:49 INFO - TEST-PASS | browser/components/uitour/test/browser_UITour_detach_tab.js | @noautohide on the menu panel should have been cleaned up -
[task 2019-09-23T11:25:49.360Z] 11:25:49 INFO - TEST-PASS | browser/components/uitour/test/browser_UITour_detach_tab.js | The panel shouldn't have @panelopen -
[task 2019-09-23T11:25:49.360Z] 11:25:49 INFO - TEST-PASS | browser/components/uitour/test/browser_UITour_detach_tab.js | The panel shouldn't be open -
[task 2019-09-23T11:25:49.360Z] 11:25:49 INFO - TEST-PASS | browser/components/uitour/test/browser_UITour_detach_tab.js | Menu button should know that the menu is closed -
[task 2019-09-23T11:25:49.360Z] 11:25:49 INFO - Done shared checks
[task 2019-09-23T11:25:49.360Z] 11:25:49 INFO - finished tests in this file
[task 2019-09-23T11:25:49.361Z] 11:25:49 INFO - GECKO(1884) | MEMORY STAT | vsize 7654MB | residentFast 377MB | heapAllocated 114MB
[task 2019-09-23T11:25:49.361Z] 11:25:49 INFO - TEST-OK | browser/components/uitour/test/browser_UITour_detach_tab.js | took 6308ms

Summary: Intermittent browser/components/uitour/test/browser_UITour_detach_tab.js | Timeout waiting for visibility: old window highlight - → Intermittent [TV] browser/components/uitour/test/browser_UITour_detach_tab.js | Timeout waiting for visibility: old window highlight -
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → INCOMPLETE
Summary: Intermittent [TV] browser/components/uitour/test/browser_UITour_detach_tab.js | Timeout waiting for visibility: old window highlight - → Intermittent browser/components/uitour/test/browser_UITour_detach_tab.js | Timeout waiting for visibility: old window highlight -

This test appears to be a permafail on ubuntu1804 fission, chunk 4:

https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&tier=1%2C2%2C3&revision=0696e1a85664bc8d7f614d8d3129529b27e4070b&searchStr=test%2Cfis

:mattn - could you please redirect the ni to someone who can take a look? Alternatively, would marking this as an expected failure on ubuntu1804 fission be an acceptable way forward?

Flags: needinfo?(MattN+bmo)

(In reply to Edwin Takahashi (:egao | high latency from 01/22-01/27) from comment #12)

This test appears to be a permafail on ubuntu1804 fission, chunk 4:

https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&tier=1%2C2%2C3&revision=0696e1a85664bc8d7f614d8d3129529b27e4070b&searchStr=test%2Cfis

:mattn - could you please redirect the ni to someone who can take a look?

Could we first figure out a regression range and ask the person who caused it? Or is this a new image/platform?

Alternatively, would marking this as an expected failure on ubuntu1804 fission be an acceptable way forward?

No, that wouldn't be correct.

Flags: needinfo?(MattN+bmo) → needinfo?(egao)

This is a new image that's been in the works for about two months and the migration of test suites to run on this image is mostly complete with just mochitest-browser-chrome as the holdout.

For a regression range, I am not certain what it may be.

Since the new image use GNOME desktop environment in contrast to the compiz window manager on ubuntu1604, my first guess is that this test needs to be updated to work with GNOME.

Flags: needinfo?(egao)
Status: REOPENED → RESOLVED
Closed: 11 months ago7 months ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 7 months ago3 months ago
Resolution: --- → INCOMPLETE

Reopening this bug because this browser_UITour_detach_tab.js test is still disabled for Fission Linux. We should try re-enabling it.

https://searchfox.org/mozilla-central/rev/82c04b9cad5b98bdf682bd477f2b1e3071b004ad/browser/components/uitour/test/browser.ini#30-31

[browser_UITour_detach_tab.js]
skip-if = fission && os == 'linux' && bits == 64 && os_version == '18.04' && !debug # Bug 1583241 for linux1804
Fission Milestone: --- → M4.1
Severity: normal → S3
Status: RESOLVED → REOPENED
Priority: P5 → P3
Resolution: INCOMPLETE → ---
Assignee: nobody → apavel
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e975c2e24113
re-enable browser_UITour_detach_tab.js on fission r=cpeterson
Status: REOPENED → RESOLVED
Closed: 3 months ago2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 80
You need to log in before you can comment on or make changes to this bug.