Closed Bug 1583290 Opened 2 years ago Closed 2 years ago

Update android x86_64 emulator to 29.2.x

Categories

(Testing :: General, task, P3)

Version 3
task

Tracking

(firefox71 fixed)

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: gbrown, Assigned: aerickson)

References

Details

Attachments

(1 file)

Most android-em tests in CI use version 29.0.11 of the android emulator. There's a new stable version available; we should upgrade if possible (I have not evaluated it).

https://androidstudio.googleblog.com/2019/09/emulator-2920-stable.html

Also note that android-em xpcshell tests still use an older version, 28.0.25; it would be great if everything could be upgraded to one emulator version.

https://searchfox.org/mozilla-central/source/testing/mozharness/configs/android/androidx86_7_0-old.py

Priority: -- → P3
See Also: → 1556058
Assignee: nobody → aerickson
Status: NEW → ASSIGNED

Sounds good. Glad you caught that.

Summary: Update android x86_64 emulator to 29.2.0 → Update android x86_64 emulator to 29.2.x
Attachment #9094973 - Attachment description: Bug 1583290: update non-old android emulator to 29.2.1 → Bug 1583290: update android emulator to 29.2.1

The xpcshell tests still have issues with the newer emulator. Only updating the 'new' manifest.

Keywords: checkin-needed

Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6c10b23b22cb
update android emulator to 29.2.1 r=gbrown

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
See Also: → 1584497
You need to log in before you can comment on or make changes to this bug.