Closed Bug 1583330 Opened 5 months ago Closed 5 months ago

Can not modify immutable data container'Can not modify immutable data container' when calling method: [calIRecurrenceInfo::appendRecurrenceItem]

Categories

(Calendar :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mkmelin, Assigned: darktrojan)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Related to or even caused by bug 1581909?

Getting a ton of these in the console

console.warn: Lightning: Message: [Exception... "Can not modify immutable data container'Can not modify immutable data container' when calling method: [calIRecurrenceInfo::appendRecurrenceItem]" nsresult: "0x80460002 (NS_ERROR_OBJECT_IS_IMMUTABLE)" location: "JS frame :: file:///home/magnus/Code/tb/mozilla/obj-x86_64-pc-linux-gnu/dist/bin/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calStorageCalendar.js :: _assureRecurringItemCaches/< :: line 1749" data: no]

https://searchfox.org/comm-central/rev/30f32c40a88dc34746d22697dad8fe99c7922054/calendar/providers/storage/calStorageCalendar.js#1749

Turns out this is caused by an idiot (me) doing things in the wrong order. Bug 1581909 didn't fix it at all.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attachment #9097527 - Flags: review?(paul)
Comment on attachment 9097527 [details] [diff] [review]
1583330-cached-item-delete-1.diff

Review of attachment 9097527 [details] [diff] [review]:
-----------------------------------------------------------------

r+ With this patch I no longer get those errors in the console, and the changes seem fine.
Attachment #9097527 - Flags: review?(paul) → review+
Keywords: checkin-needed
Target Milestone: --- → 71

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/1aad624d21ac
Delete calendar item from cache before checking it's not in the cache. r=pmorris

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Great selection of spelling errors in this code :-( - Since when it "can not" correct in English?

Sigh, that broke comm/calendar/test/unit/test_providers.js. I'll let you deal with the bustage.

Flags: needinfo?(geoff)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/0b026e14ea5d
follow-up - Stop checking item creation date is null after creating the item; rs=bustage-fix

Status: REOPENED → RESOLVED
Closed: 5 months ago5 months ago
Resolution: --- → FIXED
Flags: needinfo?(geoff)
Regressed by: 501689
You need to log in before you can comment on or make changes to this bug.