Closed Bug 158340 Opened 18 years ago Closed 18 years ago

crash [@ nsXULElement::GetOwnerDocument]

Categories

(Core :: XUL, defect, blocker)

x86
Windows 2000
defect
Not set
blocker

Tracking

()

VERIFIED DUPLICATE of bug 158202

People

(Reporter: ngh114, Assigned: sicking)

References

Details

(Keywords: crash)

Crash Data

the checkin from july 18 for bug 156452 caused 50 windows platforms to crash,
and 7  linux platforms to crash. marking as zt4newcrash and blocker. some users
were using venkman and twalker noted a "crash in wallet". for further reference
of user comments go to climate's main page and click on rank 2. stack trace below:

nsXULElement::GetOwnerDocument
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp line 931]
nsContentUtils::CheckSameOrigin
[c:/builds/seamonkey/mozilla/content/base/src/nsContentUtils.cpp line 426]
nsXULElement::InsertBefore
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp line 992]
XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp
line 106]
XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp line 1996]
XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp line
1267]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c line 790]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c line 2744]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c line 806]
nsXPCWrappedJSClass::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp line 1195]
nsXPCWrappedJS::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp line 430]
PrepareAndDispatch
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp
line 117]
SharedStub
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp
line 139]
nsEventListenerManager::HandleEventSubType
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp line
1222]
nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp line
1904]
GlobalWindowImpl::HandleDOMEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp line 763]
DocumentViewerImpl::LoadComplete
[c:/builds/seamonkey/mozilla/content/base/src/nsDocumentViewer.cpp line 1561]
nsDocShell::EndPageLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp line 4123]
nsWebShell::EndPageLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsWebShell.cpp line 723]
nsDocShell::OnStateChange
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp line 4037]
nsDocLoaderImpl::FireOnStateChange
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp line 1218]
nsDocLoaderImpl::doStopDocumentLoad
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp line 870]
nsDocLoaderImpl::DocLoaderIsEmpty
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp line 768]
nsDocLoaderImpl::DocLoaderIsEmpty
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp line 771]
nsDocLoaderImpl::OnStopRequest
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp line 699]
nsLoadGroup::RemoveRequest
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsLoadGroup.cpp line 703]
nsStreamIOChannel::OnStopRequest
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsInputStreamChannel.cpp line 486]
nsOnStopRequestEvent::HandleEvent
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsRequestObserverProxy.cpp line 213]
PL_HandleEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c line 597]
PL_ProcessPendingEvents [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c
line 530]
_md_EventReceiverProc [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c line
1078]
reassigning to sicking since sicking was the one who checked it in. cc-ing
talkback team.
Assignee: hyatt → sicking
Depends on: 156452
Keywords: crash, zt4newcrash
You are too slow

*** This bug has been marked as a duplicate of 158202 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
vrfy dupe
Status: RESOLVED → VERIFIED
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: shrir → xptoolkit.widgets
Summary: crash [ @ nsXULElement::GetOwnerDocument] → crash [@ nsXULElement::GetOwnerDocument]
Crash Signature: [@ nsXULElement::GetOwnerDocument]
You need to log in before you can comment on or make changes to this bug.