Closed Bug 1583425 Opened 3 months ago Closed 2 months ago

Search result doesn't get a11y focus in logins list

Categories

(Firefox :: about:logins, defect, P2)

70 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox70 + verified
firefox71 --- verified

People

(Reporter: Jamie, Assigned: jaws)

References

Details

(Keywords: access, Whiteboard: [passwords:management] [skyline][access-p1])

Attachments

(1 file)

Spun off bug 1580859 comment 10.

STR (with the NVDA screen reader):

  1. Open about:logins.
  2. Create a new login with the address wxyz.com, username wxyz, password wxyz.
  3. Press control+r to refresh the page.
  4. In the logins search box, type: wxyz
  5. Tab to the logins list.
    • Expected: NVDA should announce information about the item for wxyz.com.
    • Actual: NVDA just says "Logins matching search query list"
    • Note: if you interrogate with the console, aria-activedescendant is set, but it is set to a login item which has now been filtered out by the search and is thus hidden.

Note that this does not happen if the details for the affected login are being shown, hence the refresh in step 3.

Impact: This is confusing for the user, since it appears to them as if there are no search results. If there is only one search result, pressing down arrow will do nothing, which appears to confirm this incorrect understanding further. The user has to press up arrow and then down arrow to work around this.

The accessibility team considers this a P1 defect because it breaks the search feature for screen reader users. Shipping this would be a regression for screen reader users who can successfully access and utilize search in the previous implementation.

Assignee: nobody → jaws
Status: NEW → ASSIGNED

Still happy to take this for beta 13 next Monday if we can land on m-c this week.

Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/840a55a7b6d8
Update the active descendant when rendering to make sure that it is a visible list-item. r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

I have verified this issue on the latest Nightly (Build ID: 20191003214801) on Windows 7 x64 using the NVDA screen reader.

  • After performing a search and focus the login list the "Logins matching search query list" is read than the first login from the list is correctly announced.
Status: RESOLVED → VERIFIED
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla71 → Firefox 71
Version: unspecified → 70 Branch

I have verified this issue on the Firefox Beta 70.0b13 (Build ID: 20191007220302) on Windows 10 x64 using the NVDA screen reader.

  • After performing a search and focus the login list the "Logins matching search query list" is read than the first login from the list is correctly announced.
Blocks: 1583426
You need to log in before you can comment on or make changes to this bug.