Closed Bug 1583517 Opened 1 year ago Closed 1 year ago

Text input can have a gray or gray-white gradient background if it gets visible via transition

Categories

(Core :: Graphics: WebRender, defect, P2)

Unspecified
All
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- affected

People

(Reporter: violett-mozilla, Unassigned)

References

(Regression)

Details

Attachments

(2 files)

Attached image example screenshot.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

Example on codepen: https://codepen.io/mogoh/pen/dybagBr

If an input field with type=text gets visible via CSS Transition.

Actual results:

Then the color of the border gets stretched to a gradient or to the complete input field. If the mouse triggers some re-render then the background gets reset to white.

Expected results:

The background of the input should remain white.

Attached file input example.html

Hi Mogoh,

I was able to reproduce this issue on Firefox Nightly (20190930095343) with WebRender on, it does not occur with it off though.
It looks like Bug 1568227 introduced this issue.
I will set the component so that someone from the development team can take a look over this.

Thank you for reporting!

Status: UNCONFIRMED → NEW
Component: Untriaged → Graphics: WebRender
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → Core
Regressed by: 1568227
Version: 71 Branch → Trunk
Blocks: wr-71
Flags: needinfo?(nical.bugzilla)
Flags: needinfo?(jmuizelaar)
Priority: -- → P2

Can you still reproduce this with the latest Nightly?

Flags: needinfo?(jmuizelaar) → needinfo?(violett-mozilla)

I can still reproduce the issue on the latest Nightly (20191007215350)

I can't reproduce it any more, using "71.0a1 (2019-10-15) (64-Bit)". So guess it's fixed? Thank's so far! 😃

Flags: needinfo?(violett-mozilla)

Can you still reproduce this?

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(peter.magyari)
Resolution: --- → FIXED

Hi Jesse,

The issue does not occur anymore neither on Firefox 71.0a1 (2019-10-15) nor the latest Fx Nightly.

Flags: needinfo?(peter.magyari)
Flags: needinfo?(nical.bugzilla)
You need to log in before you can comment on or make changes to this bug.