Closed Bug 1583707 Opened 2 months ago Closed 2 months ago

Enable text subpixel positioning on Android and Linux

Categories

(Core :: Graphics: Text, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: lsalzman, Assigned: lsalzman)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Now that bug 1547063 has landed and we're not using Cairo for metrics anymore, we can relatively simply enable subpixel positioning on our FreeType platforms.

The idea here is that we just want to confine subpixel positioning to grayscale/subpixel AA modes for scalable outline fonts, so that we don't objectionably distort the glyphs of monochrome/bitmap fonts.

Depends on: 1547063
Blocks: 1568603
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/566dce282e2c
enable text subpixel positioning on Android and Linux. r=jfkthame
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Blocks: 939132
Blocks: 1575539
Duplicate of this bug: 1575539
Regressions: 1585931

Is bug 537190 a duplicate of this bug?

Flags: needinfo?(lsalzman)

(In reply to Asif Youssuff from comment #5)

Is bug 537190 a duplicate of this bug?

Yes

Flags: needinfo?(lsalzman)
You need to log in before you can comment on or make changes to this bug.