Closed Bug 1583713 Opened 5 months ago Closed 5 months ago

Port "Bug 1581956 - Make search-textbox not use the <textbox> tag" to Thunderbird

Categories

(Thunderbird :: General, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 71.0

People

(Reporter: mkmelin, Assigned: mkmelin)

References

Details

Attachments

(1 file, 2 obsolete files)

Looks like <textbox is="search-textbox"> is going to be changed to <search-textbox> in bug 1581956.

Attached patch bug1583713_search_textbox.patch (obsolete) — Splinter Review

Untested, but should work.

Status: NEW → ASSIGNED
Depends on: 1581956
Attached patch bug1583713_search_textbox.patch (obsolete) — Splinter Review
Attachment #9095072 - Attachment is obsolete: true

Tested, and slightly adjusted. m-c landed now so we need to land this too

Attachment #9095083 - Attachment is obsolete: true
Attachment #9095446 - Flags: review?(jorgk)
Comment on attachment 9095446 [details] [diff] [review]
bug1583713_search_textbox.patch

Hmm, 16 minutes to 12:00 noon is a little short notice. We also need a Calendar peer here.
Attachment #9095446 - Flags: review?(paul)
Attachment #9095446 - Flags: review?(jorgk)
Attachment #9095446 - Flags: review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/2059cb5adc89
Port bug 1581956: Replace textbox is="search-textbox" with search-textbox. rs=jorgk DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 71.0
Comment on attachment 9095446 [details] [diff] [review]
bug1583713_search_textbox.patch

Review of attachment 9095446 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.  I tested the calendar creation url input (that changed to html:input), and it appears to still work as intended.
Attachment #9095446 - Flags: review?(paul) → review+
You need to log in before you can comment on or make changes to this bug.