Closed Bug 158372 Opened 18 years ago Closed 18 years ago

Hang on JavaScript's infinite loop

Categories

(Core :: DOM: Core & HTML, defect, critical)

x86
Windows 2000
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 13350

People

(Reporter: lior, Assigned: jst)

References

()

Details

(Keywords: hang)

From Bugzilla Helper:
BuildID:    2002053012

When loading a page that contains a JavaScript infinite loop, mozilla stops 
responding.

Reproducible: Always
Steps to Reproduce:
go to http://www.times.co.il/test.html

Actual Results:  mozilla stops responding.

Expected Results:  mozilla should block the script.

This is the source code of the problematic script:
<script>
z = 100
for (i=0;i<z;i++) {
document.write(i);
z++;
}
</script>
Keywords: hang
Summary: crash on JavaScript's infinite loop → Hang on JavaScript's infinite loop
Over to JS engine.
Assignee: Matti → rogerl
Component: Browser-General → JavaScript Engine
QA Contact: asa → pschwartau
Browser, not engine ---> DOM Level 0
Assignee: rogerl → jst
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → DOM Level 0
Ever confirmed: true
QA Contact: pschwartau → desale
This looks like a duplicate of bug 13350,
"DOM needs to police JS infinite loops, schedule garbage collection"

Lior: thank you for this report. You will be cc'ed on bug 13350
so you can follow its progress -

*** This bug has been marked as a duplicate of 13350 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.