Closed Bug 1583777 Opened 5 months ago Closed 5 months ago

[autoconfig] Disable creation of the outgoing server depending on the incoming server alternative

Categories

(Thunderbird :: Account Manager, enhancement)

enhancement
Not set

Tracking

(thunderbird_esr6870+ fixed, thunderbird70 fixed, thunderbird71 fixed)

RESOLVED FIXED
Thunderbird 71.0
Tracking Status
thunderbird_esr68 70+ fixed
thunderbird70 --- fixed
thunderbird71 --- fixed

People

(Reporter: neil, Assigned: neil)

Details

Attachments

(1 file, 1 obsolete file)

Owl doesn't need an outgoing server so we would like the ISPDB to be able to indicate that Thunderbird shouldn't create the outgoing server when using Owl.

Attached patch Proposed patch (obsolete) — Splinter Review
Assignee: nobody → neil
Attachment #9095125 - Flags: review?(ben.bucksch)
Attachment #9095125 - Attachment is obsolete: true
Attachment #9095125 - Flags: review?(ben.bucksch)
Attachment #9095197 - Flags: review?(ben.bucksch)
Comment on attachment 9095197 [details] [diff] [review]
Updated for review comments

r=BenB
Attachment #9095197 - Flags: review?(ben.bucksch) → review+

The effect of this bug is that when the user uses the the account creation dialog and configures an Office365 account with Owl, he gets an SMTP server configured, and mail gets sent via SMTP instead of via Owl and Exchange protocol. This may or may not work, depending on the domain's configuration, so this led to broken configs for some users.

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/0932bea10bc3
Allow useGlobalPreferredServer on incoming servers too. r=BenB

Status: NEW → RESOLVED
Closed: 5 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Proper patch with 8 lines of context, correct author and commit messages. Wow ;-)

Target Milestone: --- → Thunderbird 71.0
Comment on attachment 9095197 [details] [diff] [review]
Updated for review comments

I assume you want some sort of uplift, so let's start with TB 70 beta 3 today. Please request ESR uplift if you want it.
Attachment #9095197 - Flags: approval-comm-beta+
Comment on attachment 9095197 [details] [diff] [review]
Updated for review comments

[Approval Request Comment]
Regression caused by (bug #): bug 1571772

User impact if declined: Owl configurations are broken: Some of them cannot send mail.

Testing completed (on c-c, etc.): Neil tested the TB 70 build with a local config file, and said it worked.

Risk to taking this patch (and alternatives if risky): Low
Attachment #9095197 - Flags: approval-comm-release?
Attachment #9095197 - Flags: approval-comm-release? → approval-comm-esr68+
You need to log in before you can comment on or make changes to this bug.