Closed Bug 1583868 Opened 6 months ago Closed 6 months ago

Perma GTest GeckoProfiler.Markers | Value of: strstr(profile.get(), okstr1.get()) when Gecko 71 merges to Beta on 2019-10-14

Categories

(Core :: Gecko Profiler, defect, P1)

71 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 + verified

People

(Reporter: ccoroiu, Assigned: gerald)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

Central as beta:
https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=1e201ab2a6431ff279bda043a26c927d2188c7c7&selectedJob=268353139

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=268353139&repo=try&lineNumber=26201

task 2019-09-25T13:08:51.787Z] 13:08:51 INFO - TEST-START | GeckoProfiler.Markers
[task 2019-09-25T13:08:52.461Z] 13:08:52 WARNING - TEST-UNEXPECTED-FAIL | GeckoProfiler.Markers | Value of: strstr(profile.get(), okstr1.get())
[task 2019-09-25T13:08:52.461Z] 13:08:52 INFO - Actual: false
[task 2019-09-25T13:08:52.461Z] 13:08:52 INFO - Expected: true @ /builds/worker/workspace/build/src/tools/profiler/tests/gtest/GeckoProfiler.cpp:654
[task 2019-09-25T13:08:52.461Z] 13:08:52 WARNING - TEST-UNEXPECTED-FAIL | GeckoProfiler.Markers | test completed (time: 673ms)
[task 2019-09-25T13:08:52.461Z] 13:08:52 INFO - TEST-START | GeckoProfiler.DurationLimit
[task 2019-09-25T13:08:54.178Z] 13:08:54 WARNING - TEST-UNEXPECTED-FAIL | GeckoProfiler.DurationLimit | Expected equality of these values:
[task 2019-09-25T13:08:54.178Z] 13:08:54 INFO - GTestMarkerPayload::sNumDeserialized
[task 2019-09-25T13:08:54.178Z] 13:08:54 INFO - Which is: 2
[task 2019-09-25T13:08:54.179Z] 13:08:54 INFO - 1 @ /builds/worker/workspace/build/src/tools/profiler/tests/gtest/GeckoProfiler.cpp:750
[task 2019-09-25T13:08:54.179Z] 13:08:54 WARNING - TEST-UNEXPECTED-FAIL | GeckoProfiler.DurationLimit | test completed (time: 1740ms)

Flags: needinfo?(gsquelart)
Summary: Perma Gtest GeckoProfiler.Markers | Value of: strstr(profile.get(), okstr1.get()) when Gecko 71 merges to Beta on 2019-10-14 → Perma GTest GeckoProfiler.Markers | Value of: strstr(profile.get(), okstr1.get()) when Gecko 71 merges to Beta on 2019-10-14

I can confirm that this is due to bug 1549482:

  • On Mac, stack walking availability is dependent on MOZ_PROFILING, which is only defined by default on Nightly (because frame pointers are needed, and are only available on Nightly), hence the resulting issue when moving to beta.
  • Some tests only enable the "StackWalk" feature (e.g., Profiler.Markers), which gets effectively disabled because stack walking is not available on beta/Mac.
  • Bug 1549482 "cleverly" assumed that no StackWalk/Leaf/Javascript meant the user was not interested in capturing backtraces, in which the misnamed Profiler.Markers test expects to find labels.

It would be possible to just add the "Leaf" feature to force backtraces, but I'm afraid that other tests may also rely on this (e.g., possibly bug 1584976), so I will revert part of bug 1549482, and instead add a new feature -- that was discussed as an alternative anyway, which will be less surprising to tests and people.

Assignee: nobody → gsquelart
Flags: needinfo?(gsquelart)
Keywords: regression
See Also: → 1584976
Version: unspecified → 71 Branch
See Also: 1584976

Previously, the absence of "stackwalk", "leaf", and "javascript" implied that
the test/user didn't want any sampling, but this caused issues in some tests
that enabled "stackwalk" on platforms that didn't support stack-walking, which
ended up suppressing label-only stacks that the test expected.

we now have an explicit feature "nostacksampling" that disables backtraces from
the samplers in both profilers. This effectively cancels "stackwalk", "leaf",
and "javascript" if present.

Pushed by gsquelart@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8989d1a83de8
New profiler feature "nostacksampling" - r=gregtatum
Blocks: 1583430
Blocks: 1583431
Pushed by gsquelart@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ad006751f4e4
New profiler feature "nostacksampling" - r=gregtatum
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Flags: needinfo?(gsquelart)
You need to log in before you can comment on or make changes to this bug.